SuSE 11.1 Security Update : ruby (SAT Patch Number 4585)

Medium Nessus Plugin ID 54921


The remote SuSE 11 host is missing one or more security updates.


The following several security issues of ruby have been fixed :

- A race condition allowing local users to delete arbitrary files. (CVE-2011-1004)

- Exception methods could bypass safe mode.

- webrick does not sanitize non-printable characters in log. (CVE-2009-4492)

- A webrick cross-site scripting issue. (CVE-2010-0541)

- A memory corruption in the BigDecimal class (CVE-2011-0188)


Apply SAT patch number 4585.

See Also

Plugin Details

Severity: Medium

ID: 54921

File Name: suse_11_ruby-110517.nasl

Version: $Revision: 1.4 $

Type: local

Agent: unix

Published: 2011/05/31

Modified: 2013/10/25

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 6.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:suse_linux:11:ruby, p-cpe:/a:novell:suse_linux:11:ruby-doc-html, p-cpe:/a:novell:suse_linux:11:ruby-tk, cpe:/o:novell:suse_linux:11

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/SuSE/release, Host/SuSE/rpm-list

Patch Publication Date: 2011/05/17

Reference Information

CVE: CVE-2009-4492, CVE-2010-0541, CVE-2011-0188, CVE-2011-1004, CVE-2011-1005

CWE: 20