CVE-2009-4492

MEDIUM

Description

WEBrick 1.3.1 in Ruby 1.8.6 through patchlevel 383, 1.8.7 through patchlevel 248, 1.8.8dev, 1.9.1 through patchlevel 376, and 1.9.2dev writes data to a log file without sanitizing non-printable characters, which might allow remote attackers to modify a window's title, or possibly execute arbitrary commands or overwrite files, via an HTTP request containing an escape sequence for a terminal emulator.

References

http://secunia.com/advisories/37949

http://securitytracker.com/id?1023429

http://www.redhat.com/support/errata/RHSA-2011-0908.html

http://www.redhat.com/support/errata/RHSA-2011-0909.html

http://www.ruby-lang.org/en/news/2010/01/10/webrick-escape-sequence-injection

http://www.securityfocus.com/archive/1/508830/100/0/threaded

http://www.securityfocus.com/bid/37710

http://www.ush.it/team/ush/hack_httpd_escape/adv.txt

http://www.vupen.com/english/advisories/2010/0089

Details

Source: MITRE

Published: 2010-01-13

Updated: 2018-10-10

Type: CWE-20

Risk Information

CVSS v2.0

Base Score: 5

Vector: AV:N/AC:L/Au:N/C:P/I:N/A:N

Impact Score: 2.9

Exploitability Score: 10

Severity: MEDIUM