openSUSE Security Update : kde4-kdnssd (openSUSE-SU-2010:1077-1)

Medium Nessus Plugin ID 53664


The remote openSUSE host is missing a security update.


This update of kdenetwork fixes several bugs, the security related issues are :

- CVE-2010-1000: CVSS v2 Base Score: 4.3 (AV:N/AC:M/Au:N/C:N/I:P/A:N): CWE-22 The 'name' attribute of the 'file' element of metalink files is not properly sanitised this can be exploited to download files to arbitrary directories.

- CVE-2008-4776: CVSS v2 Base Score: 4.3 (AV:N/AC:M/Au:N/C:N/I:N/A:P): CWE-119 The included libgadu version allowed remote servers to cause a denial of service (crash) via a buffer over-read.

Non-security issues :

- bnc#653852: kopete: ICQ login broken; login server changed

- bnc#516347: kopete cant connect to yahoo


Update the affected kde4-kdnssd packages.

See Also

Plugin Details

Severity: Medium

ID: 53664

File Name: suse_11_1_kde4-kdnssd-101119.nasl

Version: $Revision: 1.3 $

Type: local

Agent: unix

Published: 2011/05/05

Modified: 2014/06/13

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 5.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:kde4-kdnssd, p-cpe:/a:novell:opensuse:kde4-kget, p-cpe:/a:novell:opensuse:kde4-knewsticker, p-cpe:/a:novell:opensuse:kde4-kopete, p-cpe:/a:novell:opensuse:kde4-kopete-devel, p-cpe:/a:novell:opensuse:kde4-kppp, p-cpe:/a:novell:opensuse:kde4-krdc, p-cpe:/a:novell:opensuse:kde4-krfb, p-cpe:/a:novell:opensuse:kdenetwork4, p-cpe:/a:novell:opensuse:kdenetwork4-filesharing, cpe:/o:novell:opensuse:11.1

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2010/11/19

Reference Information

CVE: CVE-2008-4776, CVE-2010-1000

CWE: 119