CVE-2008-4776

medium
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

libgadu before 1.8.2 allows remote servers to cause a denial of service (crash) via a contact description with a large length, which triggers a buffer over-read.

References

http://lists.opensuse.org/opensuse-security-announce/2008-10/msg00012.html

http://lists.ziew.org/pipermail/libgadu-devel/2008-October/000331.html

http://www.debian.org/security/2008/dsa-1664

http://www.securityfocus.com/bid/31951

http://www.ubuntu.com/usn/usn-692-1

https://bugzilla.redhat.com/show_bug.cgi?id=468830

https://exchange.xforce.ibmcloud.com/vulnerabilities/46158

Details

Source: MITRE

Published: 2008-10-28

Updated: 2017-08-08

Type: CWE-119

Risk Information

CVSS v2

Base Score: 4.3

Vector: AV:N/AC:M/Au:N/C:N/I:N/A:P

Impact Score: 2.9

Exploitability Score: 8.6

Severity: MEDIUM

Tenable Plugins

View all (12 total)

IDNameProductFamilySeverity
79963GLSA-201412-10 : Multiple packages, Multiple vulnerabilities fixed in 2012NessusGentoo Local Security Checks
high
75547openSUSE Security Update : kdenetwork4 (openSUSE-SU-2010:1076-1)NessusSuSE Local Security Checks
medium
53739openSUSE Security Update : kdenetwork4 (openSUSE-SU-2010:1076-1)NessusSuSE Local Security Checks
medium
53668openSUSE Security Update : kdenetwork3 (openSUSE-SU-2010:1085-1)NessusSuSE Local Security Checks
medium
53664openSUSE Security Update : kde4-kdnssd (openSUSE-SU-2010:1077-1)NessusSuSE Local Security Checks
medium
51364SuSE 10 Security Update : kdenetwork (ZYPP Patch Number 7245)NessusSuSE Local Security Checks
medium
51199SuSE 11 / 11.1 Security Update : kdenetwork (SAT Patch Numbers 3563 / 3564)NessusSuSE Local Security Checks
medium
40693Mandriva Linux Security Advisory : libgadu (MDVSA-2009:208-1)NessusMandriva Local Security Checks
medium
40024openSUSE Security Update : libgadu (libgadu-272)NessusSuSE Local Security Checks
medium
36984Ubuntu 6.06 LTS / 7.10 / 8.04 LTS / 8.10 : ekg, libgadu vulnerability (USN-692-1)NessusUbuntu Local Security Checks
medium
34745Debian DSA-1664-1 : ekg - missing input sanitisingNessusDebian Local Security Checks
medium
34679openSUSE 10 Security Update : libgadu (libgadu-5717)NessusSuSE Local Security Checks
medium