SuSE 11.1 Security Update : Linux kernel (SAT Patch Numbers 2568 / 2569 / 2570)

high Nessus Plugin ID 51608
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote SuSE 11 host is missing one or more security updates.

Description

This SUSE Linux Enterprise 11 Service Pack 1 kernel update brings the Linux kernel to version 2.6.32.13. It also contains a fix for the following security issue :

- If SCTP is enabled, the sctp_process_unk_param function in net/sctp/sm_make_chunk.c allows remote attackers to cause a denial of service (system crash) via an SCTPChunkInit packet containing multiple invalid parameters that require a large amount of error data.
(CVE-2010-1173)

Additionally, the update fixes various minor bugs as documented in the kernel RPM package changelog.

Solution

Apply SAT patch number 2568 / 2569 / 2570 as appropriate.

See Also

https://bugzilla.novell.com/show_bug.cgi?id=468397

https://bugzilla.novell.com/show_bug.cgi?id=578572

https://bugzilla.novell.com/show_bug.cgi?id=580373

https://bugzilla.novell.com/show_bug.cgi?id=585385

https://bugzilla.novell.com/show_bug.cgi?id=588929

https://bugzilla.novell.com/show_bug.cgi?id=598493

https://bugzilla.novell.com/show_bug.cgi?id=598677

https://bugzilla.novell.com/show_bug.cgi?id=599508

https://bugzilla.novell.com/show_bug.cgi?id=600256

https://bugzilla.novell.com/show_bug.cgi?id=600375

https://bugzilla.novell.com/show_bug.cgi?id=602232

https://bugzilla.novell.com/show_bug.cgi?id=603387

https://bugzilla.novell.com/show_bug.cgi?id=603411

https://bugzilla.novell.com/show_bug.cgi?id=603510

https://bugzilla.novell.com/show_bug.cgi?id=605001

https://bugzilla.novell.com/show_bug.cgi?id=605321

https://bugzilla.novell.com/show_bug.cgi?id=605947

https://bugzilla.novell.com/show_bug.cgi?id=606743

https://bugzilla.novell.com/show_bug.cgi?id=606778

https://bugzilla.novell.com/show_bug.cgi?id=606797

https://bugzilla.novell.com/show_bug.cgi?id=607448

https://bugzilla.novell.com/show_bug.cgi?id=607628

https://bugzilla.novell.com/show_bug.cgi?id=607890

https://bugzilla.novell.com/show_bug.cgi?id=608435

https://bugzilla.novell.com/show_bug.cgi?id=608478

https://bugzilla.novell.com/show_bug.cgi?id=609281

https://bugzilla.novell.com/show_bug.cgi?id=610362

https://bugzilla.novell.com/show_bug.cgi?id=610598

https://bugzilla.novell.com/show_bug.cgi?id=610783

https://bugzilla.novell.com/show_bug.cgi?id=611760

https://bugzilla.novell.com/show_bug.cgi?id=613906

http://support.novell.com/security/cve/CVE-2010-1173.html

Plugin Details

Severity: High

ID: 51608

File Name: suse_11_kernel-100618.nasl

Version: 1.7

Type: local

Agent: unix

Published: 1/21/2011

Updated: 1/14/2021

Dependencies: ssh_get_info.nasl

Risk Information

VPR

Risk Factor: Medium

Score: 4.4

CVSS v2

Risk Factor: High

Base Score: 7.1

Vector: AV:N/AC:M/Au:N/C:N/I:N/A:C

Vulnerability Information

CPE: p-cpe:/a:novell:suse_linux:11:btrfs-kmp-default, p-cpe:/a:novell:suse_linux:11:btrfs-kmp-pae, p-cpe:/a:novell:suse_linux:11:btrfs-kmp-xen, p-cpe:/a:novell:suse_linux:11:ext4dev-kmp-default, p-cpe:/a:novell:suse_linux:11:ext4dev-kmp-pae, p-cpe:/a:novell:suse_linux:11:ext4dev-kmp-xen, p-cpe:/a:novell:suse_linux:11:hyper-v-kmp-default, p-cpe:/a:novell:suse_linux:11:hyper-v-kmp-pae, p-cpe:/a:novell:suse_linux:11:kernel-default, p-cpe:/a:novell:suse_linux:11:kernel-default-base, p-cpe:/a:novell:suse_linux:11:kernel-default-devel, p-cpe:/a:novell:suse_linux:11:kernel-default-extra, p-cpe:/a:novell:suse_linux:11:kernel-default-man, p-cpe:/a:novell:suse_linux:11:kernel-desktop-devel, p-cpe:/a:novell:suse_linux:11:kernel-pae, p-cpe:/a:novell:suse_linux:11:kernel-pae-base, p-cpe:/a:novell:suse_linux:11:kernel-pae-devel, p-cpe:/a:novell:suse_linux:11:kernel-pae-extra, p-cpe:/a:novell:suse_linux:11:kernel-source, p-cpe:/a:novell:suse_linux:11:kernel-syms, p-cpe:/a:novell:suse_linux:11:kernel-trace, p-cpe:/a:novell:suse_linux:11:kernel-trace-base, p-cpe:/a:novell:suse_linux:11:kernel-trace-devel, p-cpe:/a:novell:suse_linux:11:kernel-xen, p-cpe:/a:novell:suse_linux:11:kernel-xen-base, p-cpe:/a:novell:suse_linux:11:kernel-xen-devel, p-cpe:/a:novell:suse_linux:11:kernel-xen-extra, cpe:/o:novell:suse_linux:11

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/SuSE/release, Host/SuSE/rpm-list

Patch Publication Date: 6/18/2010

Reference Information

CVE: CVE-2010-1173