Adobe Reader < 9.4.1 Multiple Vulnerabilities (APSB10-28)

high Nessus Plugin ID 50614

Language:

New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The version of Adobe Reader on the remote Windows host is affected by multiple vulnerabilities.

Description

The version of Adobe Reader installed on the remote host is earlier than 9.4.1. Such versions are reportedly affected by multiple vulnerabilities :

- A memory corruption vulnerability exists that could lead to code execution. Note that this issue does not affect Adobe Reader 8.x. (CVE-2010-3654)

- An input validation issue exists that could lead to a bypass of cross-domain policy file restrictions with certain server encodings. (CVE-2010-3636)

- A memory corruption vulnerability exists in the ActiveX component. (CVE-2010-3637)

- An unspecified issue exists which could lead to a denial of service or potentially arbitrary code execution. (CVE-2010-3639)

- Multiple memory corruption issues exist that could lead to arbitrary code execution. (CVE-2010-3640, CVE-2010-3641, CVE-2010-3642, CVE-2010-3643, CVE-2010-3644, CVE-2010-3645, CVE-2010-3646, CVE-2010-3647, CVE-2010-3648, CVE-2010-3649, CVE-2010-3650, CVE-2010-3652)
- A library-loading vulnerability could lead to code execution. (CVE-2010-3976)

- A memory corruption vulnerability exists that could lead to code execution. (CVE-2010-4091)

Solution

Upgrade to Adobe Reader 9.4.1 or later.

See Also

http://www.adobe.com/support/security/bulletins/apsb10-28.html

http://www.nessus.org/u?4f6626c5

Plugin Details

Severity: High

ID: 50614

File Name: adobe_reader_apsb10-28.nasl

Version: 1.20

Type: local

Agent: windows

Family: Windows

Published: 11/16/2010

Updated: 11/15/2018

Dependencies: adobe_reader_installed.nasl

Risk Information

VPR

Risk Factor: Critical

Score: 9.7

CVSS v2

Risk Factor: High

Base Score: 9.3

Temporal Score: 8.1

Vector: AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: E:H/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:adobe:acrobat_reader

Required KB Items: SMB/Acroread/Version

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 11/16/2010

Vulnerability Publication Date: 10/28/2010

Exploitable With

CANVAS (CANVAS)

Core Impact

Metasploit (Adobe Flash Player "Button" Remote Code Execution)

Reference Information

CVE: CVE-2010-3636, CVE-2010-3637, CVE-2010-3639, CVE-2010-3640, CVE-2010-3641, CVE-2010-3642, CVE-2010-3643, CVE-2010-3644, CVE-2010-3645, CVE-2010-3646, CVE-2010-3647, CVE-2010-3648, CVE-2010-3649, CVE-2010-3650, CVE-2010-3652, CVE-2010-3654, CVE-2010-3976, CVE-2010-4091

BID: 44504, 44638, 44838

Secunia: 42030, 42095