CVE-2010-4091

HIGH
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

The EScript.api plugin in Adobe Reader and Acrobat 10.x before 10.0.1, 9.x before 9.4.1, and 8.x before 8.2.6 on Windows and Mac OS X allows remote attackers to execute arbitrary code or cause a denial of service (application crash) via a crafted PDF document that triggers memory corruption, involving the printSeps function. NOTE: some of these details are obtained from third party information.

References

http://archives.neohapsis.com/archives/fulldisclosure/2010-11/0024.html

http://blogs.adobe.com/psirt/2010/11/potential-issue-in-adobe-reader.html

http://extraexploit.blogspot.com/2010/11/full-disclosure-xplpdf-adober-reader-94.html

http://lists.opensuse.org/opensuse-security-announce/2010-12/msg00001.html

http://osvdb.org/69005

http://secunia.com/advisories/42095

http://secunia.com/advisories/42401

http://secunia.com/advisories/43025

http://security.gentoo.org/glsa/glsa-201101-08.xml

http://www.adobe.com/support/security/bulletins/apsb10-28.html

http://www.adobe.com/support/security/bulletins/apsb11-03.html

http://www.exploit-db.com/exploits/15419

http://www.redhat.com/support/errata/RHSA-2010-0934.html

http://www.securityfocus.com/bid/44638

http://www.securitytracker.com/id?1024684

http://www.securitytracker.com/id?1025033

http://www.vupen.com/english/advisories/2010/2890

http://www.vupen.com/english/advisories/2010/3111

http://www.vupen.com/english/advisories/2011/0191

http://www.vupen.com/english/advisories/2011/0337

https://exchange.xforce.ibmcloud.com/vulnerabilities/62996

https://oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.oval%3Adef%3A12527

Details

Source: MITRE

Published: 2010-11-07

Updated: 2018-10-30

Type: CWE-119

Risk Information

CVSS v2

Base Score: 9.3

Vector: AV:N/AC:M/Au:N/C:C/I:C/A:C

Impact Score: 10

Exploitability Score: 8.6

Severity: HIGH

Vulnerable Software

Configuration 1

AND

OR

cpe:2.3:a:adobe:acrobat_reader:8.0:*:*:*:*:*:*:*

cpe:2.3:a:adobe:acrobat_reader:8.1:*:*:*:*:*:*:*

cpe:2.3:a:adobe:acrobat_reader:8.1.1:*:*:*:*:*:*:*

cpe:2.3:a:adobe:acrobat_reader:8.1.2:*:*:*:*:*:*:*

cpe:2.3:a:adobe:acrobat_reader:8.1.4:*:*:*:*:*:*:*

cpe:2.3:a:adobe:acrobat_reader:8.1.5:*:*:*:*:*:*:*

cpe:2.3:a:adobe:acrobat_reader:8.1.6:*:*:*:*:*:*:*

cpe:2.3:a:adobe:acrobat_reader:8.1.7:*:*:*:*:*:*:*

cpe:2.3:a:adobe:acrobat_reader:8.2:*:*:*:*:*:*:*

cpe:2.3:a:adobe:acrobat_reader:8.2.1:*:*:*:*:*:*:*

cpe:2.3:a:adobe:acrobat_reader:8.2.2:*:*:*:*:*:*:*

cpe:2.3:a:adobe:acrobat_reader:8.2.3:*:*:*:*:*:*:*

cpe:2.3:a:adobe:acrobat_reader:8.2.4:*:*:*:*:*:*:*

cpe:2.3:a:adobe:acrobat_reader:9.0:*:*:*:*:*:*:*

cpe:2.3:a:adobe:acrobat_reader:9.1:*:*:*:*:*:*:*

cpe:2.3:a:adobe:acrobat_reader:9.1.1:*:*:*:*:*:*:*

cpe:2.3:a:adobe:acrobat_reader:9.1.2:*:*:*:*:*:*:*

cpe:2.3:a:adobe:acrobat_reader:9.1.3:*:*:*:*:*:*:*

cpe:2.3:a:adobe:acrobat_reader:9.2:*:*:*:*:*:*:*

cpe:2.3:a:adobe:acrobat_reader:9.3:*:*:*:*:*:*:*

cpe:2.3:a:adobe:acrobat_reader:9.3.1:*:*:*:*:*:*:*

cpe:2.3:a:adobe:acrobat_reader:9.3.2:*:*:*:*:*:*:*

cpe:2.3:a:adobe:acrobat_reader:9.3.3:*:*:*:*:*:*:*

cpe:2.3:a:adobe:acrobat_reader:9.3.4:*:*:*:*:*:*:*

cpe:2.3:a:adobe:acrobat_reader:9.4:*:*:*:*:*:*:*

cpe:2.3:a:adobe:acrobat_reader:10.0:*:*:*:*:*:*:*

OR

cpe:2.3:o:apple:mac_os_x:*:*:*:*:*:*:*:*

cpe:2.3:o:microsoft:windows:*:*:*:*:*:*:*:*

Configuration 2

AND

OR

cpe:2.3:a:adobe:acrobat:8.0:*:*:*:*:*:*:*

cpe:2.3:a:adobe:acrobat:8.1:*:*:*:*:*:*:*

cpe:2.3:a:adobe:acrobat:8.1.1:*:*:*:*:*:*:*

cpe:2.3:a:adobe:acrobat:8.1.2:*:*:*:*:*:*:*

cpe:2.3:a:adobe:acrobat:8.1.3:*:*:*:*:*:*:*

cpe:2.3:a:adobe:acrobat:8.1.4:*:*:*:*:*:*:*

cpe:2.3:a:adobe:acrobat:8.1.5:*:*:*:*:*:*:*

cpe:2.3:a:adobe:acrobat:8.1.6:*:*:*:*:*:*:*

cpe:2.3:a:adobe:acrobat:8.1.7:*:*:*:*:*:*:*

cpe:2.3:a:adobe:acrobat:8.2:*:*:*:*:*:*:*

cpe:2.3:a:adobe:acrobat:8.2.1:*:*:*:*:*:*:*

cpe:2.3:a:adobe:acrobat:8.2.2:*:*:*:*:*:*:*

cpe:2.3:a:adobe:acrobat:8.2.3:*:*:*:*:*:*:*

cpe:2.3:a:adobe:acrobat:8.2.4:*:*:*:*:*:*:*

cpe:2.3:a:adobe:acrobat:9.0:*:*:*:*:*:*:*

cpe:2.3:a:adobe:acrobat:9.1:*:*:*:*:*:*:*

cpe:2.3:a:adobe:acrobat:9.1.1:*:*:*:*:*:*:*

cpe:2.3:a:adobe:acrobat:9.1.2:*:*:*:*:*:*:*

cpe:2.3:a:adobe:acrobat:9.1.3:*:*:*:*:*:*:*

cpe:2.3:a:adobe:acrobat:9.2:*:*:*:*:*:*:*

cpe:2.3:a:adobe:acrobat:9.3:*:*:*:*:*:*:*

cpe:2.3:a:adobe:acrobat:9.3.1:*:*:*:*:*:*:*

cpe:2.3:a:adobe:acrobat:9.3.2:*:*:*:*:*:*:*

cpe:2.3:a:adobe:acrobat:9.3.3:*:*:*:*:*:*:*

cpe:2.3:a:adobe:acrobat:9.3.4:*:*:*:*:*:*:*

cpe:2.3:a:adobe:acrobat:9.4:*:*:*:*:*:*:*

cpe:2.3:a:adobe:acrobat:10.0:*:*:*:*:*:*:*

OR

cpe:2.3:o:apple:mac_os_x:*:*:*:*:*:*:*:*

cpe:2.3:o:microsoft:windows:*:*:*:*:*:*:*:*

Tenable Plugins

View all (19 total)

IDNameProductFamilySeverity
75421openSUSE Security Update : acroread (openSUSE-SU-2011:0156-1)NessusSuSE Local Security Checks
high
75420openSUSE Security Update : acroread (openSUSE-SU-2010:1030-1)NessusSuSE Local Security Checks
high
57745GLSA-201201-19 : Adobe Reader: Multiple vulnerabilitiesNessusGentoo Local Security Checks
critical
53693openSUSE Security Update : acroread (openSUSE-SU-2011:0156-1)NessusSuSE Local Security Checks
high
53692openSUSE Security Update : acroread (openSUSE-SU-2010:1030-1)NessusSuSE Local Security Checks
high
53651openSUSE Security Update : acroread (openSUSE-SU-2010:1030-1)NessusSuSE Local Security Checks
high
52568SuSE 10 Security Update : acroread_ja (ZYPP Patch Number 7359)NessusSuSE Local Security Checks
high
52567SuSE 10 Security Update : acroread (ZYPP Patch Number 7358)NessusSuSE Local Security Checks
high
52566SuSE 11.1 Security Update : acroread_ja (SAT Patch Number 4058)NessusSuSE Local Security Checks
high
52565SuSE 11.1 Security Update : acroread (SAT Patch Number 4057)NessusSuSE Local Security Checks
high
51925Adobe Reader < 10.0.1 / 9.4.2 / 8.2.6 Multiple Vulnerabilities (APSB11-03)NessusWindows
high
51924Adobe Acrobat < 10.0.1 / 9.4.2 / 8.2.5 Multiple Vulnerabilities (APSB11-03)NessusWindows
high
51716SuSE 10 Security Update : acroread_ja (ZYPP Patch Number 7267)NessusSuSE Local Security Checks
high
51704SuSE 10 Security Update : Acrobat Reader (ZYPP Patch Number 7266)NessusSuSE Local Security Checks
high
51657GLSA-201101-08 : Adobe Reader: Multiple vulnerabilitiesNessusGentoo Local Security Checks
high
51087SuSE 11 / 11.1 Security Update : acroread_ja (SAT Patch Numbers 3638 / 3639)NessusSuSE Local Security Checks
high
51086SuSE 11 / 11.1 Security Update : Acrobat Reader (SAT Patch Numbers 3634 / 3636)NessusSuSE Local Security Checks
high
50869RHEL 4 / 5 / 6 : acroread (RHSA-2010:0934)NessusRed Hat Local Security Checks
high
50614Adobe Reader < 9.4.1 Multiple Vulnerabilities (APSB10-28)NessusWindows
high