FreeBSD : linux-flashplugin -- multiple vulnerabilities (76b597e4-e9c6-11df-9e10-001b2134ef46)

High Nessus Plugin ID 50505


The remote FreeBSD host is missing one or more security-related updates.


Adobe Product Security Incident Response Team reports :

Critical vulnerabilities have been identified in Adobe Flash Player and earlier versions for Windows, Macintosh, Linux, and Solaris, and Adobe Flash Player for Android. These vulnerabilities, including CVE-2010-3654 referenced in Security Advisory APSA10-05, could cause the application to crash and could potentially allow an attacker to take control of the affected system.


Update the affected packages.

See Also

Plugin Details

Severity: High

ID: 50505

File Name: freebsd_pkg_76b597e4e9c611df9e10001b2134ef46.nasl

Version: $Revision: 1.13 $

Type: local

Published: 2010/11/08

Modified: 2013/11/18

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 9.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:linux-f10-flashplugin, p-cpe:/a:freebsd:freebsd:linux-f8-flashplugin, p-cpe:/a:freebsd:freebsd:linux-flashplugin, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2010/11/06

Vulnerability Publication Date: 2010/09/28

Exploitable With


Core Impact

Metasploit (Adobe Flash Player "Button" Remote Code Execution)

Reference Information

CVE: CVE-2010-3636, CVE-2010-3637, CVE-2010-3638, CVE-2010-3639, CVE-2010-3640, CVE-2010-3641, CVE-2010-3642, CVE-2010-3643, CVE-2010-3644, CVE-2010-3645, CVE-2010-3646, CVE-2010-3647, CVE-2010-3648, CVE-2010-3649, CVE-2010-3650, CVE-2010-3652, CVE-2010-3654, CVE-2010-3676