Apache 2.0.x < 2.0.64 Multiple Vulnerabilities

high Nessus Plugin ID 50069
New! Vulnerability Priority Rating (VPR)

Tenable calculates a dynamic VPR for every vulnerability. VPR combines vulnerability information with threat intelligence and machine learning algorithms to predict which vulnerabilities are most likely to be exploited in attacks. Read more about what VPR is and how it is different from CVSS.

VPR Score: 8.9


The remote web server is affected by multiple vulnerabilities.


According to its banner, the version of Apache 2.0.x running on the remote host is prior to 2.0.64. It is, therefore, affected by the following vulnerabilities :

- An unspecified error exists in the handling of requests without a path segment. (CVE-2010-1452)

- Several modules, including 'mod_deflate', are vulnerable to a denial of service attack as the server can be forced to utilize CPU time compressing a large file after client disconnect. (CVE-2009-1891)

- An unspecified error exists in 'mod_proxy' related to filtration of authentication credentials. (CVE-2009-3095)
- A NULL pointer dereference issue exists in 'mod_proxy_ftp' in some error handling paths.

- An error exists in 'mod_ssl' making the server vulnerable to the TLC renegotiation prefix injection attack. (CVE-2009-3555)

- An error exists in the handling of subrequests such that the parent request headers may be corrupted.

- An error exists in 'mod_proxy_http' when handling excessive interim responses making it vulnerable to a denial of service attack. (CVE-2008-2364)

- An error exists in 'mod_isapi' that allows the module to be unloaded too early, which leaves orphaned callback pointers. (CVE-2010-0425)

- An error exists in 'mod_proxy_ftp' when wildcards are in an FTP URL, which allows for cross-site scripting attacks. (CVE-2008-2939)

Note that the remote web server may not actually be affected by these vulnerabilities. Nessus did not try to determine whether the affected modules are in use or to check for the issues themselves.


Upgrade to Apache version 2.0.64 or later. Alternatively, ensure that the affected modules are not in use.

See Also



Plugin Details

Severity: High

ID: 50069

File Name: apache_2_0_64.nasl

Version: 1.33

Type: remote

Family: Web Servers

Published: 10/20/2010

Updated: 6/29/2018

Dependencies: apache_http_version.nasl

Risk Information

Risk Factor: High

VPR Score: 8.9

CVSS v2.0

Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:H/RL:OF/RC:C

CVSS v3.0

Base Score: 7.3

Temporal Score: 7

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS:3.0/E:H/RL:O/RC:C

Vulnerability Information

CPE: cpe:2.3:a:apache:http_server:*:*:*:*:*:*:*:*

Required KB Items: installed_sw/Apache

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 10/19/2010

Vulnerability Publication Date: 6/10/2008

Exploitable With

Core Impact

Reference Information

CVE: CVE-2010-0425, CVE-2009-3555, CVE-2010-0434, CVE-2009-3720, CVE-2010-1452, CVE-2010-1623, CVE-2008-2364, CVE-2008-2939, CVE-2009-1891, CVE-2009-2412, CVE-2009-3094, CVE-2009-3095, CVE-2009-3560

BID: 38494, 29653, 30560, 35949

CWE: 119, 189, 264, 399, 200, 79, 310

Secunia: 30261, 31384, 35781, 36549, 36675, 38776