phpMyAdmin setup.php Verbose Server Name XSS (PMASA-2010-7)

medium Nessus Plugin ID 49142
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.


The remote web server contains a PHP application that has a cross- site scripting vulnerability.


The setup script included with the version of phpMyAdmin installed on the remote host does not properly sanitize user-supplied input to the 'verbose server name' field.

A remote attacker could exploit this by tricking a user into executing arbitrary script code.


Upgrade to phpMyAdmin 3.3.7 or later.

See Also

Plugin Details

Severity: Medium

ID: 49142

File Name: phpmyadmin_pmasa_2010_7.nasl

Version: 1.16

Type: remote

Published: 9/8/2010

Updated: 1/19/2021

Dependencies: phpMyAdmin_detect.nasl

Risk Information


Risk Factor: Low

Score: 3


Risk Factor: Medium

Base Score: 4.3

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:H/RL:OF/RC:C

Vulnerability Information

CPE: cpe:2.3:a:phpmyadmin:phpmyadmin:*:*:*:*:*:*:*:*

Required KB Items: www/phpMyAdmin

Excluded KB Items: Settings/disable_cgi_scanning

Exploit Ease: No exploit is required

Exploited by Nessus: true

Patch Publication Date: 9/8/2010

Vulnerability Publication Date: 9/8/2010

Reference Information

CVE: CVE-2010-3263

CWE: 20, 79, 74, 442, 629, 711, 712, 722, 725, 750, 751, 800, 801, 809, 811, 864, 900, 928, 931, 990

TRA: TRA-2010-02