Adobe Reader < 9.3.3 / 8.2.3 Multiple Vulnerabilities (APSB10-15)

High Nessus Plugin ID 47165

Synopsis

The version of Adobe Reader on the remote Windows host is affected by multiple vulnerabilities.

Description

The version of Adobe Reader installed on the remote host is earlier than 9.3.3 / 8.2.3. Such versions are reportedly affected by multiple vulnerabilities :
- A social engineering attack could lead to code execution. (CVE-2010-1240)

- Handling of an invalid pointer could lead to code execution. (CVE-2010-1285)

- A memory corruption vulnerability could lead to code execution. (CVE-2010-1295)

- A memory corruption vulnerability could lead to code execution. This issue is reportedly being exploited in the wild. (CVE-2010-1297)

- Handling of an invalid pointer could lead to code execution. (CVE-2010-2168)

- Handling of an invalid pointer could lead to code execution. (CVE-2010-2201)

- A memory corruption vulnerability could lead to code execution. (CVE-2010-2202)

- A denial of service vulnerability could potentially lead to code execution. (CVE-2010-2204)

- It may be possible to execute arbitrary code via uninitialized memory locations. (CVE-2010-2205)

- An error in array-indexing could lead to code execution. (CVE-2010-2206)

- A memory corruption vulnerability could lead to code execution. (CVE-2010-2207)
- Dereferencing a deleted heap object could lead to code execution. (CVE-2010-2208)

- A memory corruption vulnerability could lead to code execution. (CVE-2010-2209)

- A memory corruption vulnerability could lead to code execution. (CVE-2010-2210)

- A memory corruption vulnerability could lead to code execution. (CVE-2010-2211)

- A memory corruption vulnerability could lead to code execution. (CVE-2010-2212)

Solution

Upgrade to Adobe Reader 9.3.3 / 8.2.3 or later.

See Also

http://www.adobe.com/support/security/bulletins/apsb10-15.html

Plugin Details

Severity: High

ID: 47165

File Name: adobe_reader_apsb10-15.nasl

Version: 1.54

Type: local

Agent: windows

Family: Windows

Published: 2010/06/30

Updated: 2018/09/17

Dependencies: 20836

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 9.3

Temporal Score: 8.1

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:H/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:adobe:acrobat_reader

Required KB Items: SMB/Acroread/Version

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2010/06/29

Vulnerability Publication Date: 2010/03/29

Exploitable With

CANVAS (CANVAS)

Core Impact

Metasploit (Adobe Flash Player "newfunction" Invalid Pointer Use)

ExploitHub (EH-11-164)

Reference Information

CVE: CVE-2010-1240, CVE-2010-1285, CVE-2010-1295, CVE-2010-1297, CVE-2010-2168, CVE-2010-2201, CVE-2010-2202, CVE-2010-2204, CVE-2010-2205, CVE-2010-2206, CVE-2010-2207, CVE-2010-2208, CVE-2010-2209, CVE-2010-2210, CVE-2010-2211, CVE-2010-2212

BID: 39109, 40586, 41230, 41231, 41232, 41234, 41236, 41237, 41238, 41239, 41240, 41241, 41242, 41243, 41244, 41245

Secunia: 40034