openSUSE Security Update : pyxml (pyxml-1670)

Medium Nessus Plugin ID 43345

Synopsis

The remote openSUSE host is missing a security update.

Description

Specially crafted XML documents could make pyxml run into an enless loop, therefore locking up applications using pyxml (CVE-2009-3720, CVE-2009-3560).

Solution

Update the affected pyxml package.

See Also

https://bugzilla.novell.com/show_bug.cgi?id=550666

https://bugzilla.novell.com/show_bug.cgi?id=561561

Plugin Details

Severity: Medium

ID: 43345

File Name: suse_11_0_pyxml-091210.nasl

Version: Revision: 1.6

Type: local

Agent: unix

Published: 2009/12/18

Updated: 2014/06/13

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 5

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:pyxml, cpe:/o:novell:opensuse:11.0

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2009/12/10

Reference Information

CVE: CVE-2009-3560, CVE-2009-3720

CWE: 119