openSUSE Security Update : tomcat6 (tomcat6-999)

Medium Nessus Plugin ID 40144

New! Vulnerability Priority Rating (VPR)

Tenable calculates a dynamic VPR for every vulnerability. VPR combines vulnerability information with threat intelligence and machine learning algorithms to predict which vulnerabilities are most likely to be exploited in attacks. Read more about what VPR is and how it's different from CVSS.

VPR Score: 6.2

Synopsis

The remote openSUSE host is missing a security update.

Description

This update of tomcat fixes several vulnerabilities :

- CVE-2008-5515: RequestDispatcher usage can lead to information leakage

- CVE-2009-0033: denial of service via AJP connection

- CVE-2009-0580: some authentication classes allow user enumeration

- CVE-2009-0781: XSS bug in example application cal2.jsp

- CVE-2009-0783: replacing XML parser leads to information leakage Additionally, non-security bugs were fixed.

Solution

Update the affected tomcat6 packages.

See Also

https://bugzilla.novell.com/show_bug.cgi?id=418664

https://bugzilla.novell.com/show_bug.cgi?id=424675

https://bugzilla.novell.com/show_bug.cgi?id=433852

https://bugzilla.novell.com/show_bug.cgi?id=446598

https://bugzilla.novell.com/show_bug.cgi?id=484760

https://bugzilla.novell.com/show_bug.cgi?id=485933

https://bugzilla.novell.com/show_bug.cgi?id=509839

https://bugzilla.novell.com/show_bug.cgi?id=509840

Plugin Details

Severity: Medium

ID: 40144

File Name: suse_11_0_tomcat6-090613.nasl

Version: 1.16

Type: local

Agent: unix

Published: 2009/07/21

Updated: 2019/10/25

Dependencies: 12634

Risk Information

Risk Factor: Medium

VPR Score: 6.2

CVSS v2.0

Base Score: 5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:N

CVSS v3.0

Base Score: 4.2

Vector: CVSS:3.0/AV:L/AC:L/PR:H/UI:N/S:U/C:L/I:L/A:L

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:tomcat6, p-cpe:/a:novell:opensuse:tomcat6-admin-webapps, p-cpe:/a:novell:opensuse:tomcat6-docs-webapp, p-cpe:/a:novell:opensuse:tomcat6-javadoc, p-cpe:/a:novell:opensuse:tomcat6-jsp-2_1-api, p-cpe:/a:novell:opensuse:tomcat6-lib, p-cpe:/a:novell:opensuse:tomcat6-servlet-2_5-api, p-cpe:/a:novell:opensuse:tomcat6-webapps, cpe:/o:novell:opensuse:11.0

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2009/06/13

Exploitable With

CANVAS (D2ExploitPack)

Reference Information

CVE: CVE-2008-5515, CVE-2009-0033, CVE-2009-0580, CVE-2009-0781, CVE-2009-0783

CWE: 20, 22, 79, 200