openSUSE Security Update : libapr-util1 (libapr-util1-968)

High Nessus Plugin ID 40022


The remote openSUSE host is missing a security update.


This update of libapr-util1 fixes a memory consumption bug in the XML parser that can cause a remote denial-of-service vulnerability in applications using APR (WebDAV for example) (CVE-2009-1955).
Additionally a one byte buffer overflow in function apr_brigade_vprintf() (CVE-2009-1956) and buffer underflow in function apr_strmatch_precompile() (CVE-2009-0023) was fixed too. Depending on the application using this function it can lead to remote denial of service or information leakage.


Update the affected libapr-util1 packages.

See Also

Plugin Details

Severity: High

ID: 40022

File Name: suse_11_0_libapr-util1-090608.nasl

Version: $Revision: 1.14 $

Type: local

Agent: unix

Published: 2009/07/21

Modified: 2016/12/21

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.8

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:C

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:libapr-util1, p-cpe:/a:novell:opensuse:libapr-util1-dbd-mysql, p-cpe:/a:novell:opensuse:libapr-util1-dbd-pgsql, p-cpe:/a:novell:opensuse:libapr-util1-dbd-sqlite3, p-cpe:/a:novell:opensuse:libapr-util1-devel, cpe:/o:novell:opensuse:11.0

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2009/06/08

Reference Information

CVE: CVE-2009-0023, CVE-2009-1955, CVE-2009-1956

CWE: 119, 189, 399