CVE-2009-1956

MEDIUM

Description

Off-by-one error in the apr_brigade_vprintf function in Apache APR-util before 1.3.5 on big-endian platforms allows remote attackers to obtain sensitive information or cause a denial of service (application crash) via crafted input.

References

http://lists.apple.com/archives/security-announce/2009/Nov/msg00000.html

http://marc.info/?l=bugtraq&m=129190899612998&w=2

http://secunia.com/advisories/34724

http://secunia.com/advisories/35284

http://secunia.com/advisories/35395

http://secunia.com/advisories/35487

http://secunia.com/advisories/35565

http://secunia.com/advisories/35710

http://secunia.com/advisories/35797

http://secunia.com/advisories/35843

http://secunia.com/advisories/37221

http://security.gentoo.org/glsa/glsa-200907-03.xml

http://support.apple.com/kb/HT3937

http://svn.apache.org/viewvc?view=rev&revision=768417

http://www.apache.org/dist/apr/CHANGES-APR-UTIL-1.3

http://www.mail-archive.com/[email protected]/msg21591.html

http://www.mail-archive.com/[email protected]/msg21592.html

http://www.mandriva.com/security/advisories?name=MDVSA-2009:131

http://www.mandriva.com/security/advisories?name=MDVSA-2013:150

http://www.openwall.com/lists/oss-security/2009/06/06/1

http://www.oracle.com/technetwork/topics/security/cpuapr2013-1899555.html

http://www.redhat.com/support/errata/RHSA-2009-1107.html

http://www.redhat.com/support/errata/RHSA-2009-1108.html

http://www.securityfocus.com/bid/35251

http://www.ubuntu.com/usn/usn-786-1

http://www.ubuntu.com/usn/usn-787-1

http://www.vupen.com/english/advisories/2009/1907

http://www.vupen.com/english/advisories/2009/3184

http://www-01.ibm.com/support/docview.wss?uid=swg1PK88341

http://www-01.ibm.com/support/docview.wss?uid=swg1PK91241

http://www-01.ibm.com/support/docview.wss?uid=swg1PK99478

http://www-01.ibm.com/support/docview.wss?uid=swg27014463

https://bugzilla.redhat.com/show_bug.cgi?id=504390

https://lists.apache.org/thread.html/[email protected]%3Ccvs.httpd.apache.org%3E

https://lists.apache.org/thread.html/[email protected]%3Ccvs.httpd.apache.org%3E

https://lists.apache.org/thread.html/[email protected]%3Ccvs.httpd.apache.org%3E

https://lists.apache.org/thread.html/[email protected]%3Ccvs.httpd.apache.org%3E

https://lists.apache.org/thread.html/[email protected]%3Ccvs.httpd.apache.org%3E

https://lists.apache.org/thread.html/[email protected]%3Ccvs.httpd.apache.org%3E

https://lists.apache.org/thread.html/[email protected]%3Ccvs.httpd.apache.org%3E

https://lists.apache.org/thread.html/[email protected]%3Ccvs.httpd.apache.org%3E

https://lists.apache.org/thread.html/[email protected]%3Ccvs.httpd.apache.org%3E

https://lists.apache.org/thread.html/[email protected]%3Ccvs.httpd.apache.org%3E

https://oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.oval%3Adef%3A11567

https://oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.oval%3Adef%3A12237

https://www.redhat.com/archives/fedora-package-announce/2009-June/msg01173.html

https://www.redhat.com/archives/fedora-package-announce/2009-June/msg01201.html

https://www.redhat.com/archives/fedora-package-announce/2009-June/msg01228.html

Details

Source: MITRE

Published: 2009-06-08

Updated: 2021-03-30

Type: CWE-189

Risk Information

CVSS v2.0

Base Score: 6.4

Vector: AV:N/AC:L/Au:N/C:P/I:N/A:P

Impact Score: 4.9

Exploitability Score: 10

Severity: MEDIUM

Tenable Plugins

View all (32 total)

IDNameProductFamilySeverity
67876Oracle Linux 3 : httpd (ELSA-2009-1108)NessusOracle Linux Local Security Checks
high
67875Oracle Linux 4 / 5 : apr-util (ELSA-2009-1107)NessusOracle Linux Local Security Checks
high
60598Scientific Linux Security Update : httpd on SL3.x i386/x86_64NessusScientific Linux Local Security Checks
high
60597Scientific Linux Security Update : apr-util on SL4.x, SL5.x i386/x86_64NessusScientific Linux Local Security Checks
high
43758CentOS 5 : apr-util (CESA-2009:1107)NessusCentOS Local Security Checks
high
43000Mandriva Linux Security Advisory : apr (MDVSA-2009:314)NessusMandriva Local Security Checks
critical
800795Mac OS X 10.6 < 10.6.2 Multiple VulnerabilitiesLog Correlation EngineOperating System Detection
high
5227Mac OS X 10.6 < 10.6.2 Multiple VulnerabilitiesNessus Network MonitorGeneric
critical
42434Mac OS X 10.6.x < 10.6.2 Multiple VulnerabilitiesNessusMacOS X Local Security Checks
critical
42433Mac OS X Multiple Vulnerabilities (Security Update 2009-006)NessusMacOS X Local Security Checks
critical
42010openSUSE 10 Security Update : libapr-util1 (libapr-util1-6288)NessusSuSE Local Security Checks
high
41543SuSE 10 Security Update : libapr-util1 (ZYPP Patch Number 6289)NessusSuSE Local Security Checks
high
41418SuSE 11 Security Update : libapr-util1 (SAT Patch Number 969)NessusSuSE Local Security Checks
high
41057IBM WebSphere Application Server < 6.1.0.27 Multiple VulnerabilitiesNessusWeb Servers
medium
40760FreeBSD : apache22 -- several vulnerabilities (e15f2356-9139-11de-8f42-001aa0166822)NessusFreeBSD Local Security Checks
high
800567Apache < 2.2.12 Multiple VulnerabilitiesLog Correlation EngineWeb Servers
medium
5111Apache < 2.2.12 Multiple VulnerabilitiesNessus Network MonitorWeb Servers
medium
40459Slackware 12.0 / 12.1 / 12.2 / current : httpd (SSA:2009-214-01)NessusSlackware Local Security Checks
high
40467Apache 2.2.x < 2.2.12 Multiple VulnerabilitiesNessusWeb Servers
high
40256openSUSE Security Update : libapr-util1 (libapr-util1-968)NessusSuSE Local Security Checks
high
40022openSUSE Security Update : libapr-util1 (libapr-util1-968)NessusSuSE Local Security Checks
high
39614GLSA-200907-03 : APR Utility Library: Multiple vulnerabilitiesNessusGentoo Local Security Checks
high
39505Fedora 11 : apr-util-1.3.7-1.fc11 (2009-6261)NessusFedora Local Security Checks
high
39504Fedora 9 : apr-util-1.2.12-7.fc9 (2009-6014)NessusFedora Local Security Checks
high
39503Fedora 10 : apr-util-1.3.7-1.fc10 (2009-5969)NessusFedora Local Security Checks
high
39438CentOS 3 : httpd (CESA-2009:1108)NessusCentOS Local Security Checks
high
39432RHEL 3 : httpd (RHSA-2009:1108)NessusRed Hat Local Security Checks
high
39431RHEL 4 / 5 : apr-util (RHSA-2009:1107)NessusRed Hat Local Security Checks
high
39371Ubuntu 6.06 LTS / 8.04 LTS / 8.10 / 9.04 : apache2 vulnerabilities (USN-787-1)NessusUbuntu Local Security Checks
high
39363Ubuntu 8.04 LTS / 8.10 / 9.04 : apr-util vulnerabilities (USN-786-1)NessusUbuntu Local Security Checks
high
39323Mandriva Linux Security Advisory : apr-util (MDVSA-2009:131)NessusMandriva Local Security Checks
high
39320FreeBSD : apr -- multiple vulnerabilities (eb9212f7-526b-11de-bbf2-001b77d09812)NessusFreeBSD Local Security Checks
high