FreeBSD : php5 -- potential magic_quotes_gpc vulnerability (1f9e2376-c52f-11dd-8cbc-00163e000016)

High Nessus Plugin ID 35050


The remote FreeBSD host is missing a security-related update.


PHP Developers reports :

Due to a security bug found in the PHP 5.2.7 release, it has been removed from distribution. The bug affects configurations where magic_quotes_gpc is enabled, because it remains off even when set to on.


Update the affected package.

See Also

Plugin Details

Severity: High

ID: 35050

File Name: freebsd_pkg_1f9e2376c52f11dd8cbc00163e000016.nasl

Version: $Revision: 1.10 $

Type: local

Published: 2008/12/08

Modified: 2013/06/21

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:php5, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Patch Publication Date: 2008/12/08

Vulnerability Publication Date: 2008/12/07

Reference Information

CVE: CVE-2008-5844

CWE: 16