openSUSE 10 Security Update : enscript (enscript-5719)

High Nessus Plugin ID 34709


The remote openSUSE host is missing a security update.


This update of enscript fixes buffer overflows in the setfilename (CVE-2008-3863), process_file and read_special_escape function that can be exploited during file processing.


Update the affected enscript package.

Plugin Details

Severity: High

ID: 34709

File Name: suse_enscript-5719.nasl

Version: $Revision: 1.7 $

Type: local

Agent: unix

Published: 2008/11/06

Modified: 2014/06/13

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.6

Vector: CVSS2#AV:N/AC:H/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:enscript, cpe:/o:novell:opensuse:10.2, cpe:/o:novell:opensuse:10.3

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2008/10/30

Reference Information

CVE: CVE-2008-3863

CWE: 119