CVE-2008-3863

high
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

Stack-based buffer overflow in the read_special_escape function in src/psgen.c in GNU Enscript 1.6.1 and 1.6.4 beta, when the -e (aka special escapes processing) option is enabled, allows user-assisted remote attackers to execute arbitrary code via a crafted ASCII file, related to the setfilename command.

References

http://lists.apple.com/archives/security-announce/2009/May/msg00002.html

http://lists.opensuse.org/opensuse-security-announce/2008-11/msg00000.html

http://rhn.redhat.com/errata/RHSA-2008-1021.html

http://secunia.com/advisories/32137

http://secunia.com/advisories/32521

http://secunia.com/advisories/32530

http://secunia.com/advisories/32753

http://secunia.com/advisories/32854

http://secunia.com/advisories/32970

http://secunia.com/advisories/33109

http://secunia.com/advisories/35074

http://secunia.com/secunia_research/2008-41/

http://security.gentoo.org/glsa/glsa-200812-02.xml

http://securityreason.com/securityalert/4488

http://support.apple.com/kb/HT3549

http://support.avaya.com/elmodocs2/security/ASA-2008-504.htm

http://wiki.rpath.com/wiki/Advisories:rPSA-2008-0321

http://www.debian.org/security/2008/dsa-1670

http://www.mandriva.com/security/advisories?name=MDVSA-2008:243

http://www.redhat.com/support/errata/RHSA-2008-1016.html

http://www.securityfocus.com/archive/1/497647/100/0/threaded

http://www.securityfocus.com/archive/1/498385/100/0/threaded

http://www.securityfocus.com/bid/31858

http://www.ubuntu.com/usn/usn-660-1

http://www.us-cert.gov/cas/techalerts/TA09-133A.html

http://www.vupen.com/english/advisories/2008/2891

http://www.vupen.com/english/advisories/2009/1297

https://exchange.xforce.ibmcloud.com/vulnerabilities/46026

https://issues.rpath.com/browse/RPL-2887

https://oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.oval%3Adef%3A9939

https://www.redhat.com/archives/fedora-package-announce/2008-November/msg00014.html

https://www.redhat.com/archives/fedora-package-announce/2008-November/msg00040.html

Details

Source: MITRE

Published: 2008-10-23

Updated: 2018-10-11

Type: CWE-119

Risk Information

CVSS v2

Base Score: 7.6

Vector: AV:N/AC:H/Au:N/C:C/I:C/A:C

Impact Score: 10

Exploitability Score: 4.9

Severity: HIGH

Tenable Plugins

View all (22 total)

IDNameProductFamilySeverity
67773Oracle Linux 3 / 4 : enscript (ELSA-2008-1021)NessusOracle Linux Local Security Checks
high
67771Oracle Linux 5 : enscript (ELSA-2008-1016)NessusOracle Linux Local Security Checks
high
60504Scientific Linux Security Update : enscript on SL3.x, SL4.x, SL5.x i386/x86_64NessusScientific Linux Local Security Checks
high
43718CentOS 5 : enscript (CESA-2008:1016)NessusCentOS Local Security Checks
high
41251SuSE9 Security Update : enscript (YOU Patch Number 12275)NessusSuSE Local Security Checks
high
39955openSUSE Security Update : enscript (enscript-274)NessusSuSE Local Security Checks
high
38744Mac OS X 10.5.x < 10.5.7 Multiple VulnerabilitiesNessusMacOS X Local Security Checks
critical
38743Mac OS X Multiple Vulnerabilities (Security Update 2009-002)NessusMacOS X Local Security Checks
critical
38023Ubuntu 6.06 LTS / 7.10 / 8.04 LTS / 8.10 : enscript vulnerability (USN-660-1)NessusUbuntu Local Security Checks
high
36321Mandriva Linux Security Advisory : enscript (MDVSA-2008:243)NessusMandriva Local Security Checks
high
35180RHEL 2.1 / 3 / 4 : enscript (RHSA-2008:1021)NessusRed Hat Local Security Checks
high
35178RHEL 5 : enscript (RHSA-2008:1016)NessusRed Hat Local Security Checks
high
35172CentOS 3 / 4 : enscript (CESA-2008:1021)NessusCentOS Local Security Checks
high
35019GLSA-200812-02 : enscript: User-assisted execution of arbitrary codeNessusGentoo Local Security Checks
high
34949Debian DSA-1670-1 : enscript - buffer overflowsNessusDebian Local Security Checks
high
34817FreeBSD : enscript -- arbitrary code execution vulnerability (a1126054-b57c-11dd-8892-0017319806e7)NessusFreeBSD Local Security Checks
high
34709openSUSE 10 Security Update : enscript (enscript-5719)NessusSuSE Local Security Checks
high
34708SuSE 10 Security Update : enscript (ZYPP Patch Number 5715)NessusSuSE Local Security Checks
high
34705Fedora 9 : enscript-1.6.4-10.fc9 (2008-9372)NessusFedora Local Security Checks
high
34702Fedora 8 : enscript-1.6.4-9.fc8 (2008-9351)NessusFedora Local Security Checks
high
5023Mac OS X 10.5 < 10.5.7 Multiple VulnerabilitiesNessus Network MonitorGeneric
critical
800792Mac OS X 10.5 < 10.5.7 Multiple VulnerabilitiesLog Correlation EngineOperating System Detection
high