SuSE 10 Security Update : PHP5 (ZYPP Patch Number 5661)

High Nessus Plugin ID 34429


The remote SuSE 10 host is missing a security-related patch.


This update fixes some overflows in the gd extension and the memnstr() function that could crash php or even cause a buffer overflow (CVE-2008-3658 / CVE-2008-3659) In addition it fixes a bug in gd support. (bnc#411272)


Apply ZYPP patch number 5661.

See Also

Plugin Details

Severity: High

ID: 34429

File Name: suse_apache2-mod_php5-5661.nasl

Version: $Revision: 1.12 $

Type: local

Agent: unix

Published: 2008/10/16

Modified: 2012/05/17

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: cpe:/o:suse:suse_linux

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/SuSE/release, Host/SuSE/rpm-list

Patch Publication Date: 2008/10/07

Reference Information

CVE: CVE-2008-3658, CVE-2008-3659

CWE: 119