PHP < 5.2.4 Multiple Vulnerabilities

Medium Nessus Plugin ID 25971

Synopsis

The remote web server uses a version of PHP that is affected by multiple flaws.

Description

According to its banner, the version of PHP installed on the remote host is older than 5.2.4. Such versions may be affected by various issues, including but not limited to several overflows.

Solution

Upgrade to PHP version 5.2.4 or later.

See Also

http://www.php.net/releases/5_2_4.php

Plugin Details

Severity: Medium

ID: 25971

File Name: php_5_2_4.nasl

Version: 1.20

Type: remote

Family: CGI abuses

Published: 2007/09/03

Updated: 2018/07/24

Dependencies: 48243

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 6.8

Temporal Score: 5.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:php:php

Required KB Items: www/PHP

Exploit Available: false

Exploit Ease: No exploit is required

Patch Publication Date: 2007/08/30

Vulnerability Publication Date: 2007/06/01

Reference Information

CVE: CVE-2007-1413, CVE-2007-2872, CVE-2007-3294, CVE-2007-3378, CVE-2007-3790, CVE-2007-3799, CVE-2007-3806, CVE-2007-4010, CVE-2007-4033, CVE-2007-4255, CVE-2007-4507, CVE-2007-4652, CVE-2007-4658, CVE-2007-4659, CVE-2007-4660, CVE-2007-4661, CVE-2007-4662, CVE-2007-4663

BID: 24661, 24261, 24922, 25498

CWE: 20, 22, 119, 189, 362, 399