PHP < 5.2.4 Multiple Vulnerabilities

medium Nessus Plugin ID 25971


The remote web server uses a version of PHP that is affected by multiple flaws.


According to its banner, the version of PHP installed on the remote host is older than 5.2.4. Such versions may be affected by various issues, including but not limited to several overflows.


Upgrade to PHP version 5.2.4 or later.

See Also

Plugin Details

Severity: Medium

ID: 25971

File Name: php_5_2_4.nasl

Version: 1.23

Type: remote

Family: CGI abuses

Published: 9/3/2007

Updated: 5/31/2024

Configuration: Enable thorough checks

Supported Sensors: Nessus

Enable CGI Scanning: true

Risk Information


Risk Factor: Medium

Score: 6.7


Risk Factor: Medium

Base Score: 6.8

Temporal Score: 5.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: cpe:/a:php:php

Required KB Items: www/PHP

Excluded KB Items: Settings/disable_cgi_scanning

Exploit Ease: No exploit is required

Patch Publication Date: 8/30/2007

Vulnerability Publication Date: 6/1/2007

Reference Information

CVE: CVE-2007-1413, CVE-2007-2872, CVE-2007-3294, CVE-2007-3378, CVE-2007-3790, CVE-2007-3799, CVE-2007-3806, CVE-2007-4010, CVE-2007-4033, CVE-2007-4255, CVE-2007-4507, CVE-2007-4652, CVE-2007-4658, CVE-2007-4659, CVE-2007-4660, CVE-2007-4661, CVE-2007-4662, CVE-2007-4663

BID: 24261, 24661, 24922, 25498

CWE: 119, 189, 20, 22, 362, 399