CVE-2007-1413

HIGH

Description

Buffer overflow in the snmpget function in the snmp extension in PHP 5.2.3 and earlier, including PHP 4.4.6 and probably other PHP 4 versions, allows context-dependent attackers to execute arbitrary code via a long value in the third argument (object id).

References

http://retrogod.altervista.org/php_446_snmpget_local_bof.html

http://secunia.com/advisories/24440

http://www.securityfocus.com/bid/22893

https://exchange.xforce.ibmcloud.com/vulnerabilities/35517

https://www.exploit-db.com/exploits/3439

https://www.exploit-db.com/exploits/4204

Details

Source: MITRE

Published: 2007-03-12

Updated: 2017-10-11

Type: CWE-119

Risk Information

CVSS v2.0

Base Score: 7.5

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Impact Score: 6.4

Exploitability Score: 10

Severity: HIGH