Slackware 10.0 / 10.1 / 10.2 / 11.0 / 8.1 / 9.0 / 9.1 / current : file [and bin package] (SSA:2007-093-01)

High Nessus Plugin ID 24916


The remote Slackware host is missing a security update.


New file packages are available for Slackware 8.1, 9.0, 9.1, 10.0, 10.1, 10.2, 11.0, and -current to fix a security issue. NOTE: In Slackware 11.0 and earlier, the file utility was part of the required 'bin' package, so this patch is needed even if your machine does not have a 'file' package installed (which, if you're not running Slackware -current, it probably does not).


Update the affected file package.

See Also

Plugin Details

Severity: High

ID: 24916

File Name: Slackware_SSA_2007-093-01.nasl

Version: $Revision: 1.10 $

Type: local

Published: 2007/04/05

Modified: 2013/06/01

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 9.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: p-cpe:/a:slackware:slackware_linux:file, cpe:/o:slackware:slackware_linux, cpe:/o:slackware:slackware_linux:10.0, cpe:/o:slackware:slackware_linux:10.1, cpe:/o:slackware:slackware_linux:10.2, cpe:/o:slackware:slackware_linux:11.0, cpe:/o:slackware:slackware_linux:8.1, cpe:/o:slackware:slackware_linux:9.0, cpe:/o:slackware:slackware_linux:9.1

Required KB Items: Host/local_checks_enabled, Host/Slackware/release, Host/Slackware/packages

Patch Publication Date: 2007/04/03

Vulnerability Publication Date: 2007/02/08

Reference Information

CVE: CVE-2007-1536

OSVDB: 34285

SSA: 2007-093-01