CVE-2007-1536

HIGH

Description

Integer underflow in the file_printf function in the "file" program before 4.20 allows user-assisted attackers to execute arbitrary code via a file that triggers a heap-based buffer overflow.

References

ftp://ftp.netbsd.org/pub/NetBSD/security/advisories/NetBSD-SA2008-001.txt.asc

http://docs.info.apple.com/article.html?artnum=305530

http://lists.apple.com/archives/security-announce/2007/May/msg00004.html

http://mx.gw.com/pipermail/file/2007/000161.html

http://openbsd.org/errata40.html#015_file

http://secunia.com/advisories/24548

http://secunia.com/advisories/24592

http://secunia.com/advisories/24604

http://secunia.com/advisories/24608

http://secunia.com/advisories/24616

http://secunia.com/advisories/24617

http://secunia.com/advisories/24723

http://secunia.com/advisories/24754

http://secunia.com/advisories/25133

http://secunia.com/advisories/25393

http://secunia.com/advisories/25402

http://secunia.com/advisories/25931

http://secunia.com/advisories/25989

http://secunia.com/advisories/27307

http://secunia.com/advisories/27314

http://secunia.com/advisories/29179

http://security.freebsd.org/advisories/FreeBSD-SA-07:04.file.asc

http://security.gentoo.org/glsa/glsa-200703-26.xml

http://security.gentoo.org/glsa/glsa-200710-19.xml

http://slackware.com/security/viewer.php?l=slackware-security&y=2007&m=slackware-security.512926

http://support.avaya.com/elmodocs2/security/ASA-2007-179.htm

http://www.debian.org/security/2007/dsa-1274

http://www.kb.cert.org/vuls/id/606700

http://www.mandriva.com/security/advisories?name=MDKSA-2007:067

http://www.novell.com/linux/security/advisories/2007_40_file.html

http://www.novell.com/linux/security/advisories/2007_5_sr.html

http://www.redhat.com/support/errata/RHSA-2007-0124.html

http://www.securityfocus.com/archive/1/477861/100/0/threaded

http://www.securityfocus.com/archive/1/477950/100/0/threaded

http://www.securityfocus.com/bid/23021

http://www.securitytracker.com/id?1017796

http://www.ubuntu.com/usn/usn-439-1

http://www.vupen.com/english/advisories/2007/1040

http://www.vupen.com/english/advisories/2007/1939

https://bugs.gentoo.org/show_bug.cgi?id=171452

https://exchange.xforce.ibmcloud.com/vulnerabilities/36283

https://issues.rpath.com/browse/RPL-1148

https://oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.oval%3Adef%3A10658

Details

Source: MITRE

Published: 2007-03-20

Updated: 2018-10-16

Type: CWE-189

Risk Information

CVSS v2.0

Base Score: 9.3

Vector: (AV:N/AC:M/Au:N/C:C/I:C/A:C)

Impact Score: 10

Exploitability Score: 8.6

Severity: HIGH