Adobe PDF Plug-In < 8.0 / 7.0.9 / 6.0.6 Multiple Vulnerabilities (APSB07-01)

High Nessus Plugin ID 23975


The browser plugin on the remote Windows host is affected by multiple issues.


The version of Adobe PDF Plug-In installed on the remote host is earlier than 8.0 / 7.0.9 / 6.0.6 and reportedly fails to properly sanitize input to the 'FDF', 'XML', or 'XFDF' fields used by its 'Open Parameters' feature. By tricking a user into accessing a specially crafted link and depending on the browser with which the plugin is used, a remote attacker may be able to leverage these issues to conduct arbitrary code execution, denial of service, cross-site script forgery, or cross-site scripting attacks against a user on the remote host.


Either disable displaying of PDF documents in web browsers or upgrade to Adobe Reader / Acrobat 8.0 / 7.0.9 / 6.0.6 or later.

See Also

Plugin Details

Severity: High

ID: 23975

File Name: adobe_pdf_plugin_80.nasl

Version: $Revision: 1.19 $

Type: local

Agent: windows

Family: Windows

Published: 2007/01/05

Modified: 2016/05/04

Dependencies: 13855, 21746

Risk Information

Risk Factor: High


Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:adobe:acrobat, cpe:/a:adobe:acrobat_reader

Required KB Items: SMB/Registry/Enumerated

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2007/01/09

Vulnerability Publication Date: 2006/12/27

Reference Information

CVE: CVE-2007-0044, CVE-2007-0045, CVE-2007-0046, CVE-2007-0047, CVE-2007-0048

BID: 21858

OSVDB: 31046, 31047, 31048, 31596, 34407

CERT: 815960

CWE: 352