CVE-2007-0046

HIGH
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

Double free vulnerability in the Adobe Acrobat Reader Plugin before 8.0.0, as used in Mozilla Firefox 1.5.0.7, allows remote attackers to execute arbitrary code by causing an error via a javascript: URI call to document.write in the (1) FDF, (2) XML, or (3) XFDF AJAX request parameters.

References

http://events.ccc.de/congress/2006/Fahrplan/attachments/1158-Subverting_Ajax.pdf

http://lists.suse.com/archive/suse-security-announce/2007-Jan/0012.html

http://secunia.com/advisories/23691

http://secunia.com/advisories/23812

http://secunia.com/advisories/23877

http://secunia.com/advisories/23882

http://secunia.com/advisories/24533

http://security.gentoo.org/glsa/glsa-200701-16.xml

http://securityreason.com/securityalert/2090

http://securitytracker.com/id?1017469

http://sunsolve.sun.com/search/document.do?assetkey=1-26-102847-1

http://www.adobe.com/support/security/bulletins/apsb07-01.html

http://www.redhat.com/support/errata/RHSA-2007-0021.html

http://www.securityfocus.com/archive/1/455801/100/0/threaded

http://www.vupen.com/english/advisories/2007/0032

http://www.vupen.com/english/advisories/2007/0957

http://www.wisec.it/vulns.php?page=9

https://exchange.xforce.ibmcloud.com/vulnerabilities/31272

https://oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.oval%3Adef%3A9684

https://rhn.redhat.com/errata/RHSA-2007-0017.html

Details

Source: MITRE

Published: 2007-01-03

Updated: 2018-10-16

Risk Information

CVSS v2

Base Score: 7.5

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Impact Score: 6.4

Exploitability Score: 10

Severity: HIGH

Vulnerable Software

Configuration 1

OR

cpe:2.3:a:adobe:acrobat_reader:*:*:*:*:*:*:*:* versions up to 7.0.8 (inclusive)

Tenable Plugins

View all (12 total)

IDNameProductFamilySeverity
107373Solaris 10 (sparc) : 121104-11NessusSolaris Local Security Checks
high
63836RHEL 3 : Adobe Acrobat Reader (RHSA-2007:0021)NessusRed Hat Local Security Checks
high
63835RHEL 4 : Adobe Acrobat Reader (RHSA-2007:0017)NessusRed Hat Local Security Checks
high
41117SuSE9 Security Update : acroread (YOU Patch Number 11433)NessusSuSE Local Security Checks
high
40798Adobe Acrobat < 6.0.6 / 7.0.9 Multiple VulnerabilitiesNessusWindows
high
29371SuSE 10 Security Update : acroread_ja (ZYPP Patch Number 2545)NessusSuSE Local Security Checks
high
29370SuSE 10 Security Update : acroread (ZYPP Patch Number 2508)NessusSuSE Local Security Checks
high
27144openSUSE 10 Security Update : acroread (acroread-2506)NessusSuSE Local Security Checks
high
24252GLSA-200701-16 : Adobe Acrobat Reader: Multiple vulnerabilitiesNessusGentoo Local Security Checks
high
24002Adobe Reader < 6.0.6 / 7.0.9 Multiple VulnerabilitiesNessusWindows
high
23975Adobe PDF Plug-In < 8.0 / 7.0.9 / 6.0.6 Multiple Vulnerabilities (APSB07-01)NessusWindows
high
22967Solaris 10 (sparc) : 121104-11 (deprecated)NessusSolaris Local Security Checks
high