FreeBSD : postnuke -- multiple vulnerabilities (0274a9f1-0759-11da-bc08-0001020eed82)

High Nessus Plugin ID 21379


The remote FreeBSD host is missing a security-related update.


Postnuke Security Announcementss reports of the following vulnerabilities :

- missing input validation within /modules/Messages/readpmsg.php

- possible path disclosure within /user.php

- possible path disclosure within /modules/News/article.php

- possible remote code injection within /includes/pnMod.php

- possible cross-site-scripting in /index.php

- remote code injection via xml rpc library


Update the affected package.

See Also

Plugin Details

Severity: High

ID: 21379

File Name: freebsd_pkg_0274a9f1075911dabc080001020eed82.nasl

Version: $Revision: 1.14 $

Type: local

Published: 2006/05/13

Modified: 2013/06/21

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:postnuke, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2005/08/08

Vulnerability Publication Date: 2005/05/27

Exploitable With

Metasploit (PHP XML-RPC Arbitrary Code Execution)

Reference Information

CVE: CVE-2005-1621, CVE-2005-1695, CVE-2005-1696, CVE-2005-1698, CVE-2005-1777, CVE-2005-1778, CVE-2005-1921

Secunia: 15450