Slackware 10.0 / 10.1 / 10.2 / 8.1 / 9.0 / 9.1 / current : curl/wget (SSA:2005-310-01)

High Nessus Plugin ID 20149

Synopsis

The remote Slackware host is missing a security update.

Description

New curl packages are available for Slackware 9.1, 10.0, 10.1, 10.2, and -current, and new wget packages are available for Slackware 8.1, 9.0, 9.1, 10.0, 10.1, 10.2, and -current. These address a buffer overflow in NTLM handling which may present a security problem, though no public exploits are known at this time.

Solution

Update the affected curl and / or wget packages.

See Also

http://www.nessus.org/u?642e50a1

Plugin Details

Severity: High

ID: 20149

File Name: Slackware_SSA_2005-310-01.nasl

Version: 1.11

Type: local

Published: 2005/11/07

Updated: 2018/08/09

Dependencies: 12634

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:slackware:slackware_linux:curl, p-cpe:/a:slackware:slackware_linux:wget, cpe:/o:slackware:slackware_linux, cpe:/o:slackware:slackware_linux:10.0, cpe:/o:slackware:slackware_linux:10.1, cpe:/o:slackware:slackware_linux:10.2, cpe:/o:slackware:slackware_linux:8.1, cpe:/o:slackware:slackware_linux:9.0, cpe:/o:slackware:slackware_linux:9.1

Required KB Items: Host/local_checks_enabled, Host/Slackware/release, Host/Slackware/packages

Patch Publication Date: 2005/11/06

Vulnerability Publication Date: 2005/10/13

Reference Information

CVE: CVE-2005-3185

SSA: 2005-310-01