CVE-2005-3185

high
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

Stack-based buffer overflow in the ntlm_output function in http-ntlm.c for (1) wget 1.10, (2) curl 7.13.2, and (3) libcurl 7.13.2, and other products that use libcurl, when NTLM authentication is enabled, allows remote servers to execute arbitrary code via a long NTLM username.

References

ftp://ftp.sco.com/pub/updates/OpenServer/SCOSA-2006.10/SCOSA-2006.10.txt

http://docs.info.apple.com/article.html?artnum=302847

http://lists.trustix.org/pipermail/tsl-announce/2005-October/000354.html

http://secunia.com/advisories/17192

http://secunia.com/advisories/17193

http://secunia.com/advisories/17203

http://secunia.com/advisories/17208

http://secunia.com/advisories/17228

http://secunia.com/advisories/17247

http://secunia.com/advisories/17297

http://secunia.com/advisories/17320

http://secunia.com/advisories/17400

http://secunia.com/advisories/17403

http://secunia.com/advisories/17485

http://secunia.com/advisories/17813

http://secunia.com/advisories/17965

http://secunia.com/advisories/19193

http://securityreason.com/securityalert/82

http://securitytracker.com/id?1015056

http://securitytracker.com/id?1015057

http://slackware.com/security/viewer.php?l=slackware-security&y=2005&m=slackware-security.519010

http://www.debian.org/security/2005/dsa-919

http://www.gentoo.org/security/en/glsa/glsa-200510-19.xml

http://www.idefense.com/application/poi/display?id=322&type=vulnerabilities

http://www.mandriva.com/security/advisories?name=MDKSA-2005:182

http://www.novell.com/linux/security/advisories/2005_63_wget_curl.html

http://www.osvdb.org/20011

http://www.redhat.com/archives/fedora-announce-list/2005-December/msg00020.html

http://www.redhat.com/archives/fedora-announce-list/2005-October/msg00055.html

http://www.redhat.com/support/errata/RHSA-2005-807.html

http://www.redhat.com/support/errata/RHSA-2005-812.html

http://www.securityfocus.com/bid/15102

http://www.securityfocus.com/bid/15647

http://www.vupen.com/english/advisories/2005/2088

http://www.vupen.com/english/advisories/2005/2125

http://www.vupen.com/english/advisories/2005/2659

https://exchange.xforce.ibmcloud.com/vulnerabilities/22721

https://oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.oval%3Adef%3A9810

https://usn.ubuntu.com/205-1/

Details

Source: MITRE

Published: 2005-10-13

Updated: 2018-10-03

Type: CWE-119

Risk Information

CVSS v2

Base Score: 7.5

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Impact Score: 6.4

Exploitability Score: 10

Severity: HIGH

Tenable Plugins

View all (22 total)

IDNameProductFamilySeverity
22785Debian DSA-919-2 : curl - buffer overflowNessusDebian Local Security Checks
high
21868CentOS 3 / 4 : wget (CESA-2005:812)NessusCentOS Local Security Checks
high
21864CentOS 3 / 4 : curl (CESA-2005:807)NessusCentOS Local Security Checks
high
20621Ubuntu 4.10 / 5.04 / 5.10 : curl, wget vulnerabilities (USN-205-1)NessusUbuntu Local Security Checks
high
20430Mandrake Linux Security Advisory : wget (MDKSA-2005:183)NessusMandriva Local Security Checks
high
20289Fedora Core 4 : curl-7.13.1-4.fc4 (2005-1129)NessusFedora Local Security Checks
high
3308Mac OS X Multiple Vulnerabilities (Security Update 2005-009)Nessus Network MonitorOperating System Detection
high
20249Mac OS X Multiple Vulnerabilities (Security Update 2005-009)NessusMacOS X Local Security Checks
high
20149Slackware 10.0 / 10.1 / 10.2 / 8.1 / 9.0 / 9.1 / current : curl/wget (SSA:2005-310-01)NessusSlackware Local Security Checks
high
20144RHEL 2.1 / 3 / 4 : wget (RHSA-2005:812)NessusRed Hat Local Security Checks
high
20143RHEL 3 / 4 : curl (RHSA-2005:807)NessusRed Hat Local Security Checks
high
20081GLSA-200510-19 : cURL: NTLM username stack overflowNessusGentoo Local Security Checks
high
20056Fedora Core 3 : curl-7.12.3-4.fc3 (2005-1000)NessusFedora Local Security Checks
high
20042Mandrake Linux Security Advisory : curl (MDKSA-2005:182)NessusMandriva Local Security Checks
high
3256Curl NTLM Buffer OverflowNessus Network MonitorWeb Clients
medium
3255GNU WGet < 1.10.2 Buffer OverflowNessus Network MonitorWeb Clients
medium
3112Apache < 2.0.55 HTTP Smuggling VulnerabilityNessus Network MonitorWeb Servers
high
3042Apache HTTP Request Parsing HTML Injection Nessus Network MonitorWeb Servers
high
801390Curl NTLM Buffer OverflowLog Correlation EngineWeb Clients
high
800798Mac OS X Multiple Vulnerabilities (Security Update 2005-009)Log Correlation EngineOperating System Detection
high
800576Apache HTTP Request Parsing HTML Injection Log Correlation EngineWeb Servers
high
800556Apache < 2.0.55 HTTP Smuggling VulnerabilityLog Correlation EngineWeb Servers
high