Mantis < 0.19.3 Multiple Vulnerabilities

medium Nessus Plugin ID 20093
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote web server contains a PHP application that is affected by multiple flaws.

Description

The remote version of Mantis suffers from a remote file inclusion vulnerability. Provided PHP's 'register_globals' setting is enabled, An attacker may be able to leverage this issue to read arbitrary files on the local host or to execute arbitrary PHP code, possibly taken from third-party hosts.

In addition, the installed version reportedly may be prone to SQL injection, cross-site scripting, and information disclosure attacks.

Solution

Upgrade to Mantis 0.19.3 or later.

See Also

http://secunia.com/secunia_research/2005-46/advisory/

Plugin Details

Severity: Medium

ID: 20093

File Name: mantis_file_incl_sql_inject.nasl

Version: 1.20

Type: remote

Family: CGI abuses

Published: 10/27/2005

Updated: 1/19/2021

Dependencies: mantis_detect.nasl

Risk Information

VPR

Risk Factor: Medium

Score: 5.9

CVSS v2

Risk Factor: Medium

Base Score: 6.8

Temporal Score: 5.9

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:H/RL:OF/RC:C

Vulnerability Information

CPE: cpe:2.3:a:mantisbt:mantisbt:*:*:*:*:*:*:*:*

Required KB Items: installed_sw/MantisBT

Exploit Available: true

Exploit Ease: No exploit is required

Vulnerability Publication Date: 8/22/2005

Reference Information

CVE: CVE-2005-3337, CVE-2005-3335, CVE-2005-3091, CVE-2005-3336, CVE-2005-3338, CVE-2005-3339

BID: 15212, 15227, 15210

CWE: 20, 79, 74, 442, 629, 711, 712, 722, 725, 750, 751, 800, 801, 809, 811, 864, 900, 928, 931, 990