Mantis < 1.0.0rc2 Multiple Vulnerabilities

medium Nessus Plugin ID 19473
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.


The remote web server contains a PHP application that is affected by several flaws.


According to its banner, the version of Mantis on the remote host fails to sanitize user-supplied input to the 'g_db_type' parameter of the 'core/database_api.php' script. Provided PHP's 'register_globals' setting is enabled, an attacker may be able to exploit this to connect to arbitrary databases as well as scan for arbitrary open ports, even on an internal network. In addition, it is reportedly prone to multiple cross-site scripting issues.


Upgrade to Mantis 1.0.0rc2 or later.

See Also

Plugin Details

Severity: Medium

ID: 19473

File Name: mantis_multiple_vulns4.nasl

Version: 1.25

Type: remote

Family: CGI abuses

Published: 8/22/2005

Updated: 1/19/2021

Dependencies: mantis_detect.nasl

Risk Information


Risk Factor: Medium

Score: 4.7


Risk Factor: Medium

Base Score: 4.3

Temporal Score: 3.7

Vector: AV:N/AC:M/Au:N/C:P/I:N/A:N

Temporal Vector: E:H/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:mantisbt:mantisbt

Required KB Items: installed_sw/MantisBT

Exploit Available: true

Exploit Ease: No exploit is required

Vulnerability Publication Date: 8/22/2005

Reference Information

CVE: CVE-2005-2556, CVE-2005-2557, CVE-2005-3090, CVE-2005-3091

BID: 14604

CWE: 20, 74, 79, 442, 629, 711, 712, 722, 725, 750, 751, 800, 801, 809, 811, 864, 900, 928, 931, 990