RHEL 6 / 7 : httpd24 (RHSA-2018:3558)

critical Nessus Plugin ID 194113

Synopsis

The remote Red Hat host is missing one or more security updates.

Description

The remote Redhat Enterprise Linux 6 / 7 host has packages installed that are affected by multiple vulnerabilities as referenced in the RHSA-2018:3558 advisory.

- curl: TLS session resumption client cert bypass (CVE-2016-5419)

- curl: Re-using connection with wrong client cert (CVE-2016-5420)

- curl: Use of connection struct after free (CVE-2016-5421)

- curl: Incorrect reuse of client certificates (CVE-2016-7141)

- curl: escape and unescape integer overflows (CVE-2016-7167)

- curl: Cookie injection for other servers (CVE-2016-8615)

- curl: Case insensitive password comparison (CVE-2016-8616)

- curl: Out-of-bounds write via unchecked multiplication (CVE-2016-8617)

- curl: Double-free in curl_maprintf (CVE-2016-8618)

- curl: Double-free in krb5 code (CVE-2016-8619)

- curl: Glob parser write/read out of bounds (CVE-2016-8620)

- curl: curl_getdate out-of-bounds read (CVE-2016-8621)

- curl: URL unescape heap overflow via integer truncation (CVE-2016-8622)

- curl: Use-after-free via shared cookies (CVE-2016-8623)

- curl: Invalid URL parsing with '#' (CVE-2016-8624)

- curl: IDNA 2003 makes curl use wrong host (CVE-2016-8625)

- curl: printf floating point buffer overflow (CVE-2016-9586)

- curl: --write-out out of bounds read (CVE-2017-7407)

- curl: NTLM buffer overflow via integer overflow (CVE-2017-8816)

- curl: FTP wildcard out of bounds read (CVE-2017-8817)

- httpd: Out of bounds write in mod_authnz_ldap when using too small Accept-Language values (CVE-2017-15710)

- httpd: <FilesMatch> bypass with a trailing newline in the file name (CVE-2017-15715)

- curl: TFTP sends more than buffer size (CVE-2017-1000100)

- curl: URL globbing out of bounds read (CVE-2017-1000101)

- curl: FTP PWD response parser out of bounds read (CVE-2017-1000254)

- curl: IMAP FETCH response out of bounds read (CVE-2017-1000257)

- httpd: Improper handling of headers in mod_session can allow a remote user to modify session data for CGI applications (CVE-2018-1283)

- httpd: Out of bounds access after failure in reading the HTTP request (CVE-2018-1301)

- httpd: Out of bounds read in mod_cache_socache can allow a remote attacker to cause DoS (CVE-2018-1303)

- httpd: Weak Digest auth nonce generation in mod_auth_digest (CVE-2018-1312)

- httpd: mod_http2: Too much time allocated to workers, possibly leading to DoS (CVE-2018-1333)

- httpd: DoS for HTTP/2 connections by continuous SETTINGS frames (CVE-2018-11763)

- curl: NTLM password overflow via integer overflow (CVE-2018-14618)

- curl: HTTP authentication leak in redirects (CVE-2018-1000007)

- curl: FTP path trickery leads to NIL byte out of bounds write (CVE-2018-1000120)

- curl: LDAP NULL pointer dereference (CVE-2018-1000121)

- curl: RTSP RTP buffer over-read (CVE-2018-1000122)

- curl: Out-of-bounds heap read when missing RTSP headers allows information leak or denial of service (CVE-2018-1000301)

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Update the affected packages.

See Also

https://access.redhat.com/security/updates/classification/#moderate

http://www.nessus.org/u?67615582

https://bugzilla.redhat.com/show_bug.cgi?id=1362183

https://bugzilla.redhat.com/show_bug.cgi?id=1362190

https://bugzilla.redhat.com/show_bug.cgi?id=1362199

https://bugzilla.redhat.com/show_bug.cgi?id=1373229

https://bugzilla.redhat.com/show_bug.cgi?id=1375906

https://bugzilla.redhat.com/show_bug.cgi?id=1439190

https://bugzilla.redhat.com/show_bug.cgi?id=1478309

https://bugzilla.redhat.com/show_bug.cgi?id=1478310

https://bugzilla.redhat.com/show_bug.cgi?id=1495541

https://bugzilla.redhat.com/show_bug.cgi?id=1503705

https://bugzilla.redhat.com/show_bug.cgi?id=1515757

https://bugzilla.redhat.com/show_bug.cgi?id=1515760

https://bugzilla.redhat.com/show_bug.cgi?id=1518737

https://bugzilla.redhat.com/show_bug.cgi?id=1537125

https://bugzilla.redhat.com/show_bug.cgi?id=1540167

https://bugzilla.redhat.com/show_bug.cgi?id=1552628

https://bugzilla.redhat.com/show_bug.cgi?id=1552631

https://bugzilla.redhat.com/show_bug.cgi?id=1553398

https://bugzilla.redhat.com/show_bug.cgi?id=1558450

https://bugzilla.redhat.com/show_bug.cgi?id=1560395

https://bugzilla.redhat.com/show_bug.cgi?id=1560399

https://bugzilla.redhat.com/show_bug.cgi?id=1560599

https://bugzilla.redhat.com/show_bug.cgi?id=1560614

https://bugzilla.redhat.com/show_bug.cgi?id=1560634

https://bugzilla.redhat.com/show_bug.cgi?id=1560643

https://bugzilla.redhat.com/show_bug.cgi?id=1575536

https://bugzilla.redhat.com/show_bug.cgi?id=1605048

https://bugzilla.redhat.com/show_bug.cgi?id=1622707

https://bugzilla.redhat.com/show_bug.cgi?id=1628389

https://bugzilla.redhat.com/show_bug.cgi?id=1633260

https://bugzilla.redhat.com/show_bug.cgi?id=1633399

https://bugzilla.redhat.com/show_bug.cgi?id=1634830

https://bugzilla.redhat.com/show_bug.cgi?id=1640722

https://bugzilla.redhat.com/show_bug.cgi?id=1646937

https://bugzilla.redhat.com/show_bug.cgi?id=1648928

http://www.nessus.org/u?719eab2b

https://access.redhat.com/errata/RHSA-2018:3558

https://bugzilla.redhat.com/show_bug.cgi?id=1388370

https://bugzilla.redhat.com/show_bug.cgi?id=1388371

https://bugzilla.redhat.com/show_bug.cgi?id=1388377

https://bugzilla.redhat.com/show_bug.cgi?id=1388378

https://bugzilla.redhat.com/show_bug.cgi?id=1388379

https://bugzilla.redhat.com/show_bug.cgi?id=1388382

https://bugzilla.redhat.com/show_bug.cgi?id=1388385

https://bugzilla.redhat.com/show_bug.cgi?id=1388386

https://bugzilla.redhat.com/show_bug.cgi?id=1388388

https://bugzilla.redhat.com/show_bug.cgi?id=1388390

https://bugzilla.redhat.com/show_bug.cgi?id=1388392

https://bugzilla.redhat.com/show_bug.cgi?id=1406712

Plugin Details

Severity: Critical

ID: 194113

File Name: redhat-RHSA-2018-3558.nasl

Version: 1.0

Type: local

Agent: unix

Published: 4/27/2024

Updated: 4/27/2024

Supported Sensors: Frictionless Assessment AWS, Frictionless Assessment Azure, Frictionless Assessment Agent, Nessus Agent, Agentless Assessment, Nessus

Risk Information

VPR

Risk Factor: Medium

Score: 6.7

CVSS v2

Risk Factor: Critical

Base Score: 10

Temporal Score: 7.4

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

CVSS Score Source: CVE-2018-14618

CVSS v3

Risk Factor: Critical

Base Score: 9.8

Temporal Score: 8.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/o:redhat:enterprise_linux:6, cpe:/o:redhat:enterprise_linux:7, p-cpe:/a:redhat:enterprise_linux:httpd24-curl, p-cpe:/a:redhat:enterprise_linux:httpd24-httpd, p-cpe:/a:redhat:enterprise_linux:httpd24-httpd-devel, p-cpe:/a:redhat:enterprise_linux:httpd24-httpd-manual, p-cpe:/a:redhat:enterprise_linux:httpd24-httpd-tools, p-cpe:/a:redhat:enterprise_linux:httpd24-libcurl, p-cpe:/a:redhat:enterprise_linux:httpd24-libcurl-devel, p-cpe:/a:redhat:enterprise_linux:httpd24-libnghttp2, p-cpe:/a:redhat:enterprise_linux:httpd24-libnghttp2-devel, p-cpe:/a:redhat:enterprise_linux:httpd24-mod_ldap, p-cpe:/a:redhat:enterprise_linux:httpd24-mod_md, p-cpe:/a:redhat:enterprise_linux:httpd24-mod_proxy_html, p-cpe:/a:redhat:enterprise_linux:httpd24-mod_session, p-cpe:/a:redhat:enterprise_linux:httpd24-mod_ssl, p-cpe:/a:redhat:enterprise_linux:httpd24-nghttp2

Required KB Items: Host/local_checks_enabled, Host/RedHat/release, Host/RedHat/rpm-list, Host/cpu

Exploit Ease: No known exploits are available

Patch Publication Date: 11/13/2018

Vulnerability Publication Date: 8/3/2016

Reference Information

CVE: CVE-2016-5419, CVE-2016-5420, CVE-2016-5421, CVE-2016-7141, CVE-2016-7167, CVE-2016-8615, CVE-2016-8616, CVE-2016-8617, CVE-2016-8618, CVE-2016-8619, CVE-2016-8620, CVE-2016-8621, CVE-2016-8622, CVE-2016-8623, CVE-2016-8624, CVE-2016-8625, CVE-2016-9586, CVE-2017-1000100, CVE-2017-1000101, CVE-2017-1000254, CVE-2017-1000257, CVE-2017-15710, CVE-2017-15715, CVE-2017-7407, CVE-2017-8816, CVE-2017-8817, CVE-2018-1000007, CVE-2018-1000120, CVE-2018-1000121, CVE-2018-1000122, CVE-2018-1000301, CVE-2018-11763, CVE-2018-1283, CVE-2018-1301, CVE-2018-1303, CVE-2018-1312, CVE-2018-1333, CVE-2018-14618

CWE: 120, 122, 125, 190, 20, 200, 287, 295, 305, 400, 416, 476, 787, 99

RHSA: 2018:3558