CVE-2017-8816

HIGH

Description

The NTLM authentication feature in curl and libcurl before 7.57.0 on 32-bit platforms allows attackers to cause a denial of service (integer overflow and resultant buffer overflow, and application crash) or possibly have unspecified other impact via vectors involving long user and password fields.

References

http://security.cucumberlinux.com/security/details.php?id=161

http://www.securityfocus.com/bid/101998

http://www.securitytracker.com/id/1039896

http://www.securitytracker.com/id/1040608

https://access.redhat.com/errata/RHSA-2018:3558

https://curl.haxx.se/docs/adv_2017-12e7.html

https://security.gentoo.org/glsa/201712-04

https://www.debian.org/security/2017/dsa-4051

Details

Source: MITRE

Published: 2017-11-29

Updated: 2018-11-13

Type: CWE-190

Risk Information

CVSS v2.0

Base Score: 7.5

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Impact Score: 6.4

Exploitability Score: 10

Severity: HIGH

CVSS v3.0

Base Score: 9.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Impact Score: 5.9

Exploitability Score: 3.9

Severity: CRITICAL