Slackware 10.0 / 9.1 / current : Mozilla (SSA:2004-223-01)

Critical Nessus Plugin ID 18794


The remote Slackware host is missing a security update.


New Mozilla packages are available for Slackware 9.1, 10.0, and
-current to fix a number of security issues. Slackware 10.0 and
-current were upgraded to Mozilla 1.7.2, and Slackware 9.1 was upgraded to Mozilla 1.4.3. As usual, new versions of Mozilla require new versions of things that link with the Mozilla libraries, so for Slackware 10.0 and -current new versions of epiphany, galeon, gaim, and mozilla-plugins have also been provided. There don't appear to be epiphany and galeon versions that are compatible with Mozilla 1.4.3 and the GNOME in Slackware 9.1, so these are not provided and Epiphany and Galeon will be broken on Slackware 9.1 if the new Mozilla package is installed. Furthermore, earlier versions of Mozilla (such as the 1.3 series) were not fixed upstream, so versions of Slackware earlier than 9.1 will remain vulnerable to these browser issues. If you still use Slackware 9.0 or earlier, you may want to consider removing Mozilla or upgrading to a newer version.


Update the affected packages.

See Also

Plugin Details

Severity: Critical

ID: 18794

File Name: Slackware_SSA_2004-223-01.nasl

Version: $Revision: 1.13 $

Type: local

Published: 2005/07/13

Modified: 2013/11/14

Dependencies: 12634

Risk Information

Risk Factor: Critical


Base Score: 10

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: p-cpe:/a:slackware:slackware_linux:epiphany, p-cpe:/a:slackware:slackware_linux:gaim, p-cpe:/a:slackware:slackware_linux:galeon, p-cpe:/a:slackware:slackware_linux:mozilla, p-cpe:/a:slackware:slackware_linux:mozilla-plugins, cpe:/o:slackware:slackware_linux, cpe:/o:slackware:slackware_linux:10.0, cpe:/o:slackware:slackware_linux:9.1

Required KB Items: Host/local_checks_enabled, Host/Slackware/release, Host/Slackware/packages

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2004/08/10

Reference Information

CVE: CVE-2004-0597, CVE-2004-0598, CVE-2004-0599, CVE-2004-0718, CVE-2004-0722, CVE-2004-0757, CVE-2004-0758, CVE-2004-0759, CVE-2004-0760, CVE-2004-0761, CVE-2004-0762, CVE-2004-0763, CVE-2004-0764, CVE-2004-0765

SSA: 2004-223-01