Slackware Linux 15.0 / current php Multiple Vulnerabilities (SSA:2022-164-01)

high Nessus Plugin ID 162169

Synopsis

The remote Slackware Linux host is missing a security update to php.

Description

The version of php installed on the remote host is prior to 7.4.30. It is, therefore, affected by multiple vulnerabilities as referenced in the SSA:2022-164-01 advisory.

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade the affected php package.

Plugin Details

Severity: High

ID: 162169

File Name: Slackware_SSA_2022-164-01.nasl

Version: 1.4

Type: local

Published: 6/13/2022

Updated: 8/22/2022

Risk Information

VPR

Risk Factor: High

Score: 8.4

CVSS v2

Risk Factor: Medium

Base Score: 6.8

Temporal Score: 5

Vector: AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: E:U/RL:OF/RC:C

CVSS Score Source: CVE-2022-31625

CVSS v3

Risk Factor: High

Base Score: 8.8

Temporal Score: 7.7

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: E:U/RL:O/RC:C

CVSS Score Source: CVE-2022-31626

Vulnerability Information

CPE: p-cpe:/a:slackware:slackware_linux:php, cpe:/o:slackware:slackware_linux, cpe:/o:slackware:slackware_linux:15.0

Required KB Items: Host/local_checks_enabled, Host/Slackware/release, Host/Slackware/packages

Exploit Ease: No known exploits are available

Reference Information

CVE: CVE-2022-31625, CVE-2022-31626