openSUSE 15 Security Update : libxls (openSUSE-SU-2022:0142-1)

medium Nessus Plugin ID 161430

Synopsis

The remote SUSE host is missing a security update.

Description

The remote SUSE Linux SUSE15 host has packages installed that are affected by a vulnerability as referenced in the openSUSE-SU-2022:0142-1 advisory.

- An issue was discoverered in in function xls_getWorkSheet in xls.c in libxls 1.6.2, allows attackers to cause a denial of service, via a crafted XLS file. (CVE-2021-27836)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Update the affected libxls-devel, libxls-tools and / or libxlsreader8 packages.

See Also

https://bugzilla.suse.com/1192323

http://www.nessus.org/u?82e81516

https://www.suse.com/security/cve/CVE-2021-27836

Plugin Details

Severity: Medium

ID: 161430

File Name: openSUSE-2022-0142-1.nasl

Version: 1.2

Type: local

Agent: unix

Published: 5/22/2022

Updated: 5/22/2022

Supported Sensors: Nessus Agent

Risk Information

VPR

Risk Factor: Low

Score: 3.6

CVSS v2

Risk Factor: Medium

Base Score: 4.3

Temporal Score: 3.2

Vector: AV:N/AC:M/Au:N/C:N/I:N/A:P

Temporal Vector: E:U/RL:OF/RC:C

CVSS Score Source: CVE-2021-27836

CVSS v3

Risk Factor: Medium

Base Score: 6.5

Temporal Score: 5.7

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:libxls-devel, p-cpe:/a:novell:opensuse:libxls-tools, p-cpe:/a:novell:opensuse:libxlsreader8, cpe:/o:novell:opensuse:15.3

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/SuSE/release, Host/SuSE/rpm-list

Exploit Ease: No known exploits are available

Patch Publication Date: 5/21/2022

Vulnerability Publication Date: 11/3/2021

Reference Information

CVE: CVE-2021-27836