Amazon Corretto Java 8.x < 8.242.07.1 Multiple Vulnerabilities

high Nessus Plugin ID 159402

Synopsis

Amazon Corretto is affected by multiple vulnerabilities.

Description

The version of Amazon Corretto installed on the remote host is prior to 8 < 8.242.07.1. It is, therefore, affected by multiple vulnerabilities as referenced in the corretto-8-2020-Jan-14 advisory.

- OpenJFX (libxslt) (CVE-2019-13117, CVE-2019-13118)

- OpenJFX (SQLite) (CVE-2019-16168)

- Serialization (CVE-2020-2583, CVE-2020-2604)

- OpenJFX (CVE-2020-2585)

- Security (CVE-2020-2590, CVE-2020-2601)

- Networking (CVE-2020-2593, CVE-2020-2659)

- Libraries (CVE-2020-2654)

- JSSE (CVE-2020-2655)

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Update to Amazon Corretto Java 8.242.07.1 or later

See Also

http://www.nessus.org/u?c34d25e7

Plugin Details

Severity: High

ID: 159402

File Name: amazon_corretto_8_242_07_1.nasl

Version: 1.4

Type: local

Agent: windows, macosx, unix

Family: Misc.

Published: 4/1/2022

Updated: 4/11/2022

Configuration: Enable thorough checks

Supported Sensors: Nessus Agent

Risk Information

VPR

Risk Factor: Medium

Score: 6.7

CVSS v2

Risk Factor: Medium

Base Score: 6.8

Temporal Score: 5

Vector: AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: E:U/RL:OF/RC:C

CVSS Score Source: CVE-2020-2604

CVSS v3

Risk Factor: High

Base Score: 8.1

Temporal Score: 7.1

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:amazon:corretto

Required KB Items: installed_sw/Java

Exploit Ease: No known exploits are available

Patch Publication Date: 1/14/2020

Vulnerability Publication Date: 6/30/2019

Reference Information

CVE: CVE-2019-13117, CVE-2019-13118, CVE-2019-16168, CVE-2020-2583, CVE-2020-2585, CVE-2020-2590, CVE-2020-2593, CVE-2020-2601, CVE-2020-2604, CVE-2020-2654, CVE-2020-2655, CVE-2020-2659

IAVA: 2020-A-0021-S