WordPress 5.7 < 5.7.1 / 5.6 < 5.6.3 / 5.5 < 5.5.4 / 5.4 < 5.4.5 / 5.3 < 5.3.7 / 5.2 < 5.2.10 / 5.1 < 5.1.9 / 5.0 < 5.0.12 / 4.9 < 4.9.17 / 4.8 < 4.8.16 / 4.7 < 4.7.20

medium Nessus Plugin ID 148844
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

A PHP application running on the remote web server is affected by a multiple vulnerabilities.

Description

WordPress 5.7 < 5.7.1 / 5.6 < 5.6.3 / 5.5 < 5.5.4 / 5.4 < 5.4.5 / 5.3 < 5.3.7 / 5.2 < 5.2.10 / 5.1 < 5.1.9 / 5.0 < 5.0.12 / 4.9 < 4.9.17 / 4.8 < 4.8.16 / 4.7 < 4.7.20 is affected by multiple vulnerabilities:

- A user with the ability to upload files (like an Author) can exploit an XML parsing issue in the Media Library leading to XXE attacks. This requires WordPress installation to be using PHP 8. Access to internal files is possible in a successful XXE attack. (CVE-2021-29447)

- One of the blocks in the WordPress editor can be exploited in a way that exposes password-protected posts and pages. This requires at least contributor privileges. (CVE-2021-29450)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade to WordPress version 5.7.1, 5.6.3, 5.5.4, 5.4.5, 5.3.7, 5.2.10, 5.1.9, 5.0.12, 4.9.17, 4.8.16, 4.7.10, or later.

See Also

http://www.nessus.org/u?00aa3f86

https://wordpress.org/support/wordpress-version/version-5-7-1/

https://wordpress.org/download/releases/

Plugin Details

Severity: Medium

ID: 148844

File Name: wordpress_5_7_1.nasl

Version: 1.8

Type: remote

Family: CGI abuses

Published: 4/20/2021

Updated: 9/16/2021

Dependencies: wordpress_detect.nasl

Configuration: Enable paranoid mode

Risk Information

CVSS Score Source: CVE-2021-29450

VPR

Risk Factor: Medium

Score: 6.1

CVSS v2

Risk Factor: Medium

Base Score: 4

Temporal Score: 3.1

Vector: AV:N/AC:L/Au:S/C:P/I:N/A:N

Temporal Vector: E:POC/RL:OF/RC:C

CVSS v3

Risk Factor: Medium

Base Score: 4.3

Temporal Score: 3.9

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N

Temporal Vector: E:P/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:wordpress:wordpress

Required KB Items: www/PHP, installed_sw/WordPress, Settings/ParanoidReport

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 4/15/2021

Vulnerability Publication Date: 4/15/2021

Reference Information

CVE: CVE-2021-29447, CVE-2021-29450

IAVA: 2021-A-0182-S