pfSense < 2.4.4-p3 Multiple Vulnerabilities

high Nessus Plugin ID 146430
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote firewall host is affected by multiple vulnerabilities.

Description

According to its self-reported version number, the remote pfSense install is a version prior to 2.4.4-p3. It is, therefore, affected by multiple vulnerabilities, including the following:

- In pfSense 2.4.4_1, blocking of source IP addresses on the basis of failed HTTPS authentication is inconsistent with blocking of source IP addresses on the basis of failed SSH authentication (the behavior does not match the sshguard documentation), which might make it easier for attackers to bypass intended access restrictions. (CVE-2018-20799)

- The expiretable configuration in pfSense 2.4.4_1 establishes block durations that are incompatible with the block durations implemented by sshguard, which might make it easier for attackers to bypass intended access restrictions. (CVE-2018-20798)

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to pfSense version 2.4.4-p3 or later, or apply patches as noted in the vendor advisory.

See Also

http://www.nessus.org/u?b623e2bf

http://www.nessus.org/u?391d5f25

http://www.nessus.org/u?8a534c25

http://www.nessus.org/u?0a49b8ac

http://www.nessus.org/u?66f728f6

http://www.nessus.org/u?bb2ee7ba

http://www.nessus.org/u?0697d7a9

http://www.nessus.org/u?e41356b2

https://docs.netgate.com/pfsense/en/latest/releases/2-4-4-p3.html

Plugin Details

Severity: High

ID: 146430

File Name: pfsense_2_4_4_p3.nasl

Version: 1.2

Type: remote

Family: Firewalls

Published: 2/11/2021

Updated: 2/12/2021

Dependencies: pfsense_detect.nbin

Risk Information

CVSS Score Source: CVE-2018-20798

VPR

Risk Factor: Low

Score: 3.6

CVSS v2

Risk Factor: Medium

Base Score: 5

Temporal Score: 3.7

Vector: AV:N/AC:L/Au:N/C:N/I:P/A:N

Temporal Vector: E:U/RL:OF/RC:C

CVSS v3

Risk Factor: High

Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:pfsense:pfsense, cpe:/a:bsdperimeter:pfsense, cpe:/a:netgate:pfsense

Required KB Items: Host/pfSense

Exploit Ease: No known exploits are available

Patch Publication Date: 1/29/2019

Vulnerability Publication Date: 1/29/2019

Reference Information

CVE: CVE-2018-20798, CVE-2018-20799