openSUSE Security Update : kubernetes (openSUSE-2020-554) (Dirty COW)

High Nessus Plugin ID 136011

Synopsis

The remote openSUSE host is missing a security update.

Description

This update introduces kubernetes version 1.14.1 and cri-o 1.17.1 to Leap 15.1.

Solution

Update the affected kubernetes packages.

See Also

https://bugzilla.opensuse.org/show_bug.cgi?id=1039663

https://bugzilla.opensuse.org/show_bug.cgi?id=1042383

https://bugzilla.opensuse.org/show_bug.cgi?id=1042387

https://bugzilla.opensuse.org/show_bug.cgi?id=1057277

https://bugzilla.opensuse.org/show_bug.cgi?id=1059207

https://bugzilla.opensuse.org/show_bug.cgi?id=1061027

https://bugzilla.opensuse.org/show_bug.cgi?id=1065972

https://bugzilla.opensuse.org/show_bug.cgi?id=1069469

https://bugzilla.opensuse.org/show_bug.cgi?id=1084765

https://bugzilla.opensuse.org/show_bug.cgi?id=1084766

https://bugzilla.opensuse.org/show_bug.cgi?id=1085009

https://bugzilla.opensuse.org/show_bug.cgi?id=1086185

https://bugzilla.opensuse.org/show_bug.cgi?id=1086412

https://bugzilla.opensuse.org/show_bug.cgi?id=1095131

https://bugzilla.opensuse.org/show_bug.cgi?id=1095154

https://bugzilla.opensuse.org/show_bug.cgi?id=1096773

https://bugzilla.opensuse.org/show_bug.cgi?id=1097473

https://bugzilla.opensuse.org/show_bug.cgi?id=1100838

https://bugzilla.opensuse.org/show_bug.cgi?id=1101010

https://bugzilla.opensuse.org/show_bug.cgi?id=1104598

https://bugzilla.opensuse.org/show_bug.cgi?id=1104821

https://bugzilla.opensuse.org/show_bug.cgi?id=1112980

https://bugzilla.opensuse.org/show_bug.cgi?id=1118897

https://bugzilla.opensuse.org/show_bug.cgi?id=1118898

https://bugzilla.opensuse.org/show_bug.cgi?id=1136403

https://bugzilla.opensuse.org/show_bug.cgi?id=1144065

https://bugzilla.opensuse.org/show_bug.cgi?id=1155323

https://bugzilla.opensuse.org/show_bug.cgi?id=1161056

https://bugzilla.opensuse.org/show_bug.cgi?id=1161179

https://features.opensuse.org/325820

https://features.opensuse.org/326485

Plugin Details

Severity: High

ID: 136011

File Name: openSUSE-2020-554.nasl

Version: 1.2

Type: local

Agent: unix

Published: 2020/04/27

Updated: 2020/04/29

Dependencies: 12634

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:H/RL:OF/RC:C

CVSS v3.0

Base Score: 9.8

Temporal Score: 9.4

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:H/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:cri-o, p-cpe:/a:novell:opensuse:cri-o-kubeadm-criconfig, p-cpe:/a:novell:opensuse:cri-tools, p-cpe:/a:novell:opensuse:go1.14, p-cpe:/a:novell:opensuse:go1.14-race, p-cpe:/a:novell:opensuse:kubernetes-apiserver, p-cpe:/a:novell:opensuse:kubernetes-client, p-cpe:/a:novell:opensuse:kubernetes-controller-manager, p-cpe:/a:novell:opensuse:kubernetes-kubeadm, p-cpe:/a:novell:opensuse:kubernetes-kubelet-common, p-cpe:/a:novell:opensuse:kubernetes-kubelet1.17, p-cpe:/a:novell:opensuse:kubernetes-kubelet1.18, p-cpe:/a:novell:opensuse:kubernetes-master, p-cpe:/a:novell:opensuse:kubernetes-node, p-cpe:/a:novell:opensuse:kubernetes-proxy, p-cpe:/a:novell:opensuse:kubernetes-scheduler, cpe:/o:novell:opensuse:15.1

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2020/04/26

Vulnerability Publication Date: 2016/11/10

Exploitable With

CANVAS (CANVAS)

Core Impact

Reference Information

CVE: CVE-2016-5195, CVE-2016-8859, CVE-2017-1002101, CVE-2018-1002105, CVE-2018-16873, CVE-2018-16874, CVE-2019-10214