Debian DSA-4527-1 : php7.3 - security update

Medium Nessus Plugin ID 129073

Synopsis

The remote Debian host is missing a security-related update.

Description

Multiple security issues were found in PHP, a widely-used open source general purpose scripting language: Missing sanitising in the EXIF extension and the iconv_mime_decode_headers() function could result in information disclosure or denial of service.

Solution

Upgrade the php7.3 packages.

For the stable distribution (buster), these problems have been fixed in version 7.3.9-1~deb10u1.

See Also

https://security-tracker.debian.org/tracker/source-package/php7.3

https://packages.debian.org/source/buster/php7.3

https://www.debian.org/security/2019/dsa-4527

Plugin Details

Severity: Medium

ID: 129073

File Name: debian_DSA-4527.nasl

Version: 1.3

Type: local

Agent: unix

Published: 2019/09/20

Updated: 2019/12/27

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 6.4

Temporal Score: 4.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 9.1

Temporal Score: 7.9

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:php7.3, cpe:/o:debian:debian_linux:10.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Exploit Ease: No known exploits are available

Patch Publication Date: 2019/09/19

Vulnerability Publication Date: 2019/05/03

Reference Information

CVE: CVE-2019-11036, CVE-2019-11039, CVE-2019-11040, CVE-2019-11041, CVE-2019-11042

DSA: 4527