CVE-2019-11041

high
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

When PHP EXIF extension is parsing EXIF information from an image, e.g. via exif_read_data() function, in PHP versions 7.1.x below 7.1.31, 7.2.x below 7.2.21 and 7.3.x below 7.3.8 it is possible to supply it with data what will cause it to read past the allocated buffer. This may lead to information disclosure or crash.

References

https://bugs.php.net/bug.php?id=78222

https://lists.debian.org/debian-lts-announce/2019/08/msg00010.html

https://usn.ubuntu.com/4097-2/

https://usn.ubuntu.com/4097-1/

https://security.netapp.com/advisory/ntap-20190822-0003/

https://seclists.org/bugtraq/2019/Sep/35

https://www.debian.org/security/2019/dsa-4527

https://seclists.org/bugtraq/2019/Sep/38

https://www.debian.org/security/2019/dsa-4529

http://lists.opensuse.org/opensuse-security-announce/2019-10/msg00019.html

https://support.apple.com/kb/HT210634

https://seclists.org/bugtraq/2019/Oct/9

http://seclists.org/fulldisclosure/2019/Oct/15

http://seclists.org/fulldisclosure/2019/Oct/55

https://access.redhat.com/errata/RHSA-2019:3299

https://support.apple.com/kb/HT210722

Details

Source: MITRE

Published: 2019-08-09

Updated: 2021-07-22

Type: CWE-125

Risk Information

CVSS v2

Base Score: 5.8

Vector: AV:N/AC:M/Au:N/C:P/I:N/A:P

Impact Score: 4.9

Exploitability Score: 8.6

Severity: MEDIUM

CVSS v3

Base Score: 7.1

Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:N/A:H

Impact Score: 4.2

Exploitability Score: 2.8

Severity: HIGH

Tenable Plugins

View all (36 total)

IDNameProductFamilySeverity
152986Tenable SecurityCenter < 5.19.0 Multiple Vulnerabilities (TNS-2021-14)NessusMisc.
high
151985Tenable.sc < 5.19.0 Multiple Vulnerabilities (TNS-2021-14) (deprecated)NessusMisc.
high
150598SUSE SLES11 Security Update : php53 (SUSE-SU-2019:14158-1)NessusSuSE Local Security Checks
high
145957CentOS 8 : php:7.3 (CESA-2020:3662)NessusCentOS Local Security Checks
critical
145814CentOS 8 : php:7.2 (CESA-2020:1624)NessusCentOS Local Security Checks
critical
140482Oracle Linux 8 : php:7.3 (ELSA-2020-3662)NessusOracle Linux Local Security Checks
critical
140396RHEL 8 : php:7.3 (RHSA-2020:3662)NessusRed Hat Local Security Checks
critical
137966EulerOS Virtualization 3.0.6.0 : php (EulerOS-SA-2020-1747)NessusHuawei Local Security Checks
critical
136057RHEL 8 : php:7.2 (RHSA-2020:1624)NessusRed Hat Local Security Checks
critical
134199SUSE SLES12 Security Update : php5 (SUSE-SU-2020:0522-1)NessusSuSE Local Security Checks
critical
131732PHP 7.4.x < 7.4.0 Multiple Vulnerabilities.NessusCGI abuses
critical
131592EulerOS 2.0 SP2 : php (EulerOS-SA-2019-2438)NessusHuawei Local Security Checks
critical
130967macOS 10.15.x < 10.15.1 / 10.14.x < 10.14.6 Security Update 2019-001 / 10.13.x < 10.13.6 Security Update 2019-006NessusMacOS X Local Security Checks
critical
130057macOS < 10.15 Multiple VulnerabilitiesNessusMacOS X Local Security Checks
high
129672openSUSE Security Update : php7 (openSUSE-2019-2272)NessusSuSE Local Security Checks
high
129671openSUSE Security Update : php7 (openSUSE-2019-2271)NessusSuSE Local Security Checks
high
129527SUSE SLED15 / SLES15 Security Update : php7 (SUSE-SU-2019:2503-1)NessusSuSE Local Security Checks
high
129448EulerOS 2.0 SP8 : php (EulerOS-SA-2019-2089)NessusHuawei Local Security Checks
high
129236EulerOS 2.0 SP3 : php (EulerOS-SA-2019-2043)NessusHuawei Local Security Checks
critical
129107Debian DSA-4529-1 : php7.0 - security updateNessusDebian Local Security Checks
critical
129073Debian DSA-4527-1 : php7.3 - security updateNessusDebian Local Security Checks
critical
129011Amazon Linux AMI : php72 (ALAS-2019-1284)NessusAmazon Linux Local Security Checks
high
129010Amazon Linux AMI : php71 / php73 (ALAS-2019-1283)NessusAmazon Linux Local Security Checks
critical
128931EulerOS Virtualization for ARM 64 3.0.2.0 : php (EulerOS-SA-2019-1928)NessusHuawei Local Security Checks
critical
128473SUSE SLES12 Security Update : php72 (SUSE-SU-2019:2270-1)NessusSuSE Local Security Checks
high
128317SUSE SLES12 Security Update : php7 (SUSE-SU-2019:2243-1)NessusSuSE Local Security Checks
high
98663PHP 7.1.x < 7.1.31 Multiple VulnerabilitiesWeb Application ScanningComponent Vulnerability
high
98662PHP 7.2.x < 7.2.21 Multiple VulnerabilitiesWeb Application ScanningComponent Vulnerability
high
98661PHP 7.3.x < 7.3.8 Multiple VulnerabilitiesWeb Application ScanningComponent Vulnerability
high
127892Ubuntu 16.04 LTS / 18.04 LTS / 19.04 : PHP vulnerabilities (USN-4097-1)NessusUbuntu Local Security Checks
high
127820Debian DLA-1878-1 : php5 security updateNessusDebian Local Security Checks
high
127537Fedora 29 : php (2019-f07db8f031)NessusFedora Local Security Checks
high
127535Fedora 30 : php (2019-ec40d89812)NessusFedora Local Security Checks
high
127132PHP 7.3.x < 7.3.8 Multiple Vulnerabilities.NessusCGI abuses
high
127131PHP 7.2.x < 7.2.21 Multiple Vulnerabilities.NessusCGI abuses
high
127130PHP 7.1.x < 7.1.31 Multiple Vulnerabilities.NessusCGI abuses
high