GLSA-201904-06 : GlusterFS: Multiple Vulnerabilities

High Nessus Plugin ID 123580

Synopsis

The remote Gentoo host is missing one or more security-related patches.

Description

The remote host is affected by the vulnerability described in GLSA-201904-06 (GlusterFS: Multiple Vulnerabilities)

Multiple vulnerabilities have been discovered in GlusterFS. Please review the referenced CVE identifiers for details.
Impact :

Please review the referenced CVE identifiers for details.
Workaround :

There is no known workaround at this time.

Solution

All GlusterFS users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=sys-cluster/glusterfs-4.1.8'

See Also

https://security.gentoo.org/glsa/201904-06

Plugin Details

Severity: High

ID: 123580

File Name: gentoo_GLSA-201904-06.nasl

Version: 1.1

Type: local

Published: 2019/04/02

Updated: 2019/04/02

Dependencies: 12634

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 8.5

Vector: CVSS2#AV:N/AC:L/Au:S/C:N/I:C/A:C

CVSS v3.0

Base Score: 8.8

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:glusterfs, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2019/04/02

Vulnerability Publication Date: 2018/04/18

Reference Information

CVE: CVE-2018-10841, CVE-2018-1088, CVE-2018-10904, CVE-2018-10907, CVE-2018-10911, CVE-2018-10913, CVE-2018-10914, CVE-2018-10923, CVE-2018-10924, CVE-2018-10926, CVE-2018-10927, CVE-2018-10928, CVE-2018-10929, CVE-2018-10930, CVE-2018-14651, CVE-2018-14652, CVE-2018-14653, CVE-2018-14654, CVE-2018-14659, CVE-2018-14660, CVE-2018-14661

GLSA: 201904-06