CVE-2018-14651

MEDIUM

Description

It was found that the fix for CVE-2018-10927, CVE-2018-10928, CVE-2018-10929, CVE-2018-10930, and CVE-2018-10926 was incomplete. A remote, authenticated attacker could use one of these flaws to execute arbitrary code, create arbitrary files, or cause denial of service on glusterfs server nodes via symlinks to relative paths.

References

https://access.redhat.com/errata/RHSA-2018:3431

https://access.redhat.com/errata/RHSA-2018:3432

https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2018-14651

https://lists.debian.org/debian-lts-announce/2018/11/msg00003.html

https://security.gentoo.org/glsa/201904-06

Details

Source: MITRE

Published: 2018-10-31

Updated: 2019-04-02

Type: CWE-59

Risk Information

CVSS v2.0

Base Score: 6.5

Vector: AV:N/AC:L/Au:S/C:P/I:P/A:P

Impact Score: 6.4

Exploitability Score: 8

Severity: MEDIUM

CVSS v3.0

Base Score: 8.8

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Impact Score: 5.9

Exploitability Score: 2.8

Severity: HIGH