CVE-2018-14653

MEDIUM

Description

The Gluster file system through versions 4.1.4 and 3.12 is vulnerable to a heap-based buffer overflow in the '__server_getspec' function via the 'gf_getspec_req' RPC message. A remote authenticated attacker could exploit this to cause a denial of service or other potential unspecified impact.

References

https://access.redhat.com/errata/RHSA-2018:3431

https://access.redhat.com/errata/RHSA-2018:3432

https://access.redhat.com/errata/RHSA-2018:3470

https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2018-14653

https://lists.debian.org/debian-lts-announce/2018/11/msg00003.html

https://security.gentoo.org/glsa/201904-06

Details

Source: MITRE

Published: 2018-10-31

Updated: 2019-04-02

Type: CWE-119

Risk Information

CVSS v2.0

Base Score: 6.5

Vector: AV:N/AC:L/Au:S/C:P/I:P/A:P

Impact Score: 6.4

Exploitability Score: 8

Severity: MEDIUM

CVSS v3.0

Base Score: 8.8

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Impact Score: 5.9

Exploitability Score: 2.8

Severity: HIGH