SUSE SLED15 / SLES15 Security Update : webkit2gtk3 (SUSE-SU-2018:2752-1)

High Nessus Plugin ID 120100

Synopsis

The remote SUSE host is missing one or more security updates.

Description

This update for webkit2gtk3 to version 2.20.5 fixes the following issues :

Security issue fixed :

CVE-2018-12911: Fix off-by-one in xdg_mime_get_simple_globs (bsc#1101999).

CVE-2018-4261, CVE-2018-4262, CVE-2018-4263, CVE-2018-4264, CVE-2018-4265, CVE-2018-4267, CVE-2018-4272, CVE-2018-4284: Processing maliciously crafted web content may lead to arbitrary code execution.
A memory corruption issue was addressed with improved memory handling.

CVE-2018-4266: A malicious website may be able to cause a denial of service. A race condition was addressed with additional validation.

CVE-2018-4270, CVE-2018-4271, CVE-2018-4273: Processing maliciously crafted web content may lead to an unexpected application crash. A memory corruption issue was addressed with improved input validation.

CVE-2018-4278: A malicious website may exfiltrate audio data cross-origin. Sound fetched through audio elements may be exfiltrated cross-origin. This issue was addressed with improved audio taint tracking.

Other bugs fixed: Fix rendering artifacts in some websites due to a bug introduced in 2.20.4.

Fix a crash when leaving accelerated compositing mode.

Fix non-deterministic build failure due to missing JavaScriptCore/JSContextRef.h.

Note that Tenable Network Security has extracted the preceding description block directly from the SUSE security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.

Solution

To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or 'zypper patch'.

Alternatively you can run the command listed for your product :

SUSE Linux Enterprise Module for Desktop Applications 15:zypper in -t patch SUSE-SLE-Module-Desktop-Applications-15-2018-1921=1

SUSE Linux Enterprise Module for Basesystem 15:zypper in -t patch SUSE-SLE-Module-Basesystem-15-2018-1921=1

See Also

https://bugzilla.suse.com/show_bug.cgi?id=1101999

https://bugzilla.suse.com/show_bug.cgi?id=1104169

https://www.suse.com/security/cve/CVE-2018-12911/

https://www.suse.com/security/cve/CVE-2018-4261/

https://www.suse.com/security/cve/CVE-2018-4262/

https://www.suse.com/security/cve/CVE-2018-4263/

https://www.suse.com/security/cve/CVE-2018-4264/

https://www.suse.com/security/cve/CVE-2018-4265/

https://www.suse.com/security/cve/CVE-2018-4266/

https://www.suse.com/security/cve/CVE-2018-4267/

https://www.suse.com/security/cve/CVE-2018-4270/

https://www.suse.com/security/cve/CVE-2018-4271/

https://www.suse.com/security/cve/CVE-2018-4272/

https://www.suse.com/security/cve/CVE-2018-4273/

https://www.suse.com/security/cve/CVE-2018-4278/

https://www.suse.com/security/cve/CVE-2018-4284/

http://www.nessus.org/u?a72486d2

Plugin Details

Severity: High

ID: 120100

File Name: suse_SU-2018-2752-1.nasl

Version: 1.1

Type: local

Agent: unix

Published: 2019/01/02

Updated: 2019/01/02

Dependencies: 12634

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

CVSS v3.0

Base Score: 9.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: p-cpe:/a:novell:suse_linux:libjavascriptcoregtk-4_0, p-cpe:/a:novell:suse_linux:libjavascriptcoregtk-4_0-18-debuginfo, p-cpe:/a:novell:suse_linux:libwebkit2gtk-4_0, p-cpe:/a:novell:suse_linux:libwebkit2gtk-4_0-37-debuginfo, p-cpe:/a:novell:suse_linux:typelib-1_0-JavaScriptCore, p-cpe:/a:novell:suse_linux:typelib-1_0-WebKit2, p-cpe:/a:novell:suse_linux:typelib-1_0-WebKit2WebExtension, p-cpe:/a:novell:suse_linux:webkit2gtk-4_0-injected-bundles, p-cpe:/a:novell:suse_linux:webkit2gtk-4_0-injected-bundles-debuginfo, p-cpe:/a:novell:suse_linux:webkit2gtk3-debugsource, p-cpe:/a:novell:suse_linux:webkit2gtk3-devel, cpe:/o:novell:suse_linux:15

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/SuSE/release, Host/SuSE/rpm-list

Patch Publication Date: 2018/09/19

Reference Information

CVE: CVE-2018-12911, CVE-2018-4261, CVE-2018-4262, CVE-2018-4263, CVE-2018-4264, CVE-2018-4265, CVE-2018-4266, CVE-2018-4267, CVE-2018-4270, CVE-2018-4271, CVE-2018-4272, CVE-2018-4273, CVE-2018-4278, CVE-2018-4284