PHP 5.6.x < 5.6.39 Arbitrary Command Injection Vulnerability

High Nessus Plugin ID 119764

Synopsis

An application installed on the remote host is affected by
an arbitrary command injection vulnerability.

Description

According to its banner, the version of PHP running on the remote web
server is 5.6.x prior to 5.6.39. It is, therefore, affected by
an arbitrary command injection vulnerability via the IMAP_open
mailbox parameter.

Solution

Upgrade to PHP version 5.6.39 or later.

See Also

http://php.net/ChangeLog-5.php#5.6.39

Plugin Details

Severity: High

ID: 119764

File Name: php_5_6_39.nasl

Version: 1.3

Type: remote

Family: CGI abuses

Published: 2018/12/19

Modified: 2019/01/30

Dependencies: 48243

Risk Information

Risk Factor: High

CVSS Score Source: CVE-2018-19518

CVSS v2.0

Base Score: 9.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

CVSS v3.0

Base Score: 8.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: cpe:/a:php:php

Patch Publication Date: 2018/12/06

Vulnerability Publication Date: 2018/11/14

Reference Information

CVE: CVE-2018-19518, CVE-2018-19935

IAVB: 2018-B-0157