CVE-2018-19935

high
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

ext/imap/php_imap.c in PHP 5.x and 7.x before 7.3.0 allows remote attackers to cause a denial of service (NULL pointer dereference and application crash) via an empty string in the message argument to the imap_mail function.

References

http://lists.opensuse.org/opensuse-security-announce/2019-06/msg00041.html

http://lists.opensuse.org/opensuse-security-announce/2019-06/msg00044.html

http://www.securityfocus.com/bid/106143

https://bugs.php.net/bug.php?id=77020

https://lists.debian.org/debian-lts-announce/2018/12/msg00006.html

https://security.netapp.com/advisory/ntap-20181221-0003/

https://www.debian.org/security/2018/dsa-4353

Details

Source: MITRE

Published: 2018-12-07

Updated: 2019-06-18

Type: CWE-476

Risk Information

CVSS v2

Base Score: 5

Vector: AV:N/AC:L/Au:N/C:N/I:N/A:P

Impact Score: 2.9

Exploitability Score: 10

Severity: MEDIUM

CVSS v3

Base Score: 7.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Impact Score: 3.6

Exploitability Score: 3.9

Severity: HIGH

Tenable Plugins

View all (16 total)

IDNameProductFamilySeverity
132812EulerOS Virtualization for ARM 64 3.0.5.0 : php (EulerOS-SA-2020-1058)NessusHuawei Local Security Checks
critical
132616EulerOS 2.0 SP8 : php (EulerOS-SA-2020-1023)NessusHuawei Local Security Checks
high
126035openSUSE Security Update : php7 (openSUSE-2019-1573)NessusSuSE Local Security Checks
critical
126034openSUSE Security Update : php7 (openSUSE-2019-1572)NessusSuSE Local Security Checks
critical
125850SUSE SLED15 / SLES15 Security Update : php7 (SUSE-SU-2019:1461-1)NessusSuSE Local Security Checks
critical
122394openSUSE Security Update : php7 (openSUSE-2019-207)NessusSuSE Local Security Checks
critical
122146SUSE SLES12 Security Update : php7 (SUSE-SU-2019:0333-1)NessusSuSE Local Security Checks
critical
121510PHP 7.1.x < 7.1.26 Multiple vulnerabilities.NessusCGI abuses
critical
121353PHP 7.2.x < 7.2.14 Multiple vulnerabilities.NessusCGI abuses
critical
121132Amazon Linux AMI : php56 / php70,php71,php72 (ALAS-2019-1147)NessusAmazon Linux Local Security Checks
high
120854Fedora 28 : php (2018-dfe1f0bac6)NessusFedora Local Security Checks
high
120566Fedora 29 : php (2018-7ebfe1e6f2)NessusFedora Local Security Checks
high
119764PHP 5.6.x < 5.6.39 Multiple vulnerabilitiesNessusCGI abuses
high
119695Debian DLA-1608-1 : php5 security updateNessusDebian Local Security Checks
high
119561Debian DSA-4353-1 : php7.0 - security updateNessusDebian Local Security Checks
high
111217PHP 7.3.0 [alpha|beta] < 7.3.0 Multiple vulnerabilitiesNessusCGI abuses
high