PostgreSQL 9.3.x < 9.3.25 / 9.4.x < 9.4.20 / 9.5.x < 9.5.15 / 9.6.x < 9.6.11 / 10.x < 10.6 / 11.x < 11.1 SQL injection

Medium Nessus Plugin ID 118936

Synopsis

The remote database server is affected by an SQL injection vulnerability.

Description

The version of PostgreSQL installed on the remote host is 9.3.x prior to 9.3.25, 9.4.x prior to 9.4.20, 9.5.x prior to 9.5.15, 9.6.x prior to 9.6.11, 10.x prior to 10.6, or 11.x prior to 11.1.
It is, therefore, affected by following vulnerability:

- An SQL injection (SQLi) vulnerability exists in pg_upgrade and pg_dump via CREATE TRIGGER ... REFERENCING. An authenticated, remote attacker can exploit this to execute arbitrary SQL statements with superuser privileges.

Solution

Upgrade to PostgreSQL version 9.3.25 / 9.4.20 / 9.5.15 / 9.6.11 / 10.6 / 11.1 or later.

See Also

https://www.postgresql.org/about/news/1905/

https://www.postgresql.org/docs/current/release-9-3-25.html

https://www.postgresql.org/docs/current/release-9-4-20.html

https://www.postgresql.org/docs/current/release-9-5-15.html

https://www.postgresql.org/docs/current/release-9-6-11.html

https://www.postgresql.org/docs/current/release-10-6.html

https://www.postgresql.org/docs/current/release-11-1.html

Plugin Details

Severity: Medium

ID: 118936

File Name: postgresql_20181108.nasl

Version: 1.8

Type: local

Family: Databases

Published: 2018/11/14

Updated: 2019/05/30

Dependencies: 63346

Risk Information

Risk Factor: Medium

CVSS Score Source: manual

CVSS Score Rationale: Score based on analysis of the vendor advisory.

CVSS v2.0

Base Score: 6.5

Vector: CVSS2#AV:N/AC:L/Au:S/C:P/I:P/A:P

CVSS v3.0

Base Score: 9.9

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H

Vulnerability Information

CPE: cpe:/a:postgresql:postgresql

Patch Publication Date: 2018/11/08

Vulnerability Publication Date: 2018/11/08

Reference Information

CVE: CVE-2018-16850

BID: 105923