CVE-2018-16850

HIGH

Description

postgresql before versions 11.1, 10.6 is vulnerable to a to SQL injection in pg_upgrade and pg_dump via CREATE TRIGGER ... REFERENCING. Using a purpose-crafted trigger definition, an attacker can cause arbitrary SQL statements to run, with superuser privileges.

References

http://www.securityfocus.com/bid/105923

http://www.securitytracker.com/id/1042144

https://access.redhat.com/errata/RHSA-2018:3757

https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2018-16850

https://security.gentoo.org/glsa/201811-24

https://usn.ubuntu.com/3818-1/

https://www.postgresql.org/about/news/1905/

Details

Source: MITRE

Published: 2018-11-13

Updated: 2018-12-18

Type: CWE-89

Risk Information

CVSS v2.0

Base Score: 7.5

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Impact Score: 6.4

Exploitability Score: 10

Severity: HIGH

CVSS v3.0

Base Score: 9.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Impact Score: 5.9

Exploitability Score: 3.9

Severity: CRITICAL