openSUSE Security Update : libgit2 (openSUSE-2018-1314)

Medium Nessus Plugin ID 118486

Synopsis

The remote openSUSE host is missing a security update.

Description

This update for libgit2 fixes the following issues :

- CVE-2018-8099: Fixed possible denial of service attack
via different vectors by not being able to differentiate
between these status codes (bsc#1085256).

- CVE-2018-11235: With a crafted .gitmodules file, a
malicious project can execute an arbitrary script on a
machine that runs 'git clone --recurse-submodules'
because submodule 'names' are obtained from this file,
and then appended to $GIT_DIR/modules, leading to
directory traversal with '../' in a name. Finally,
post-checkout hooks from a submodule are executed,
bypassing the intended design in which hooks are not
obtained from a remote server. (bsc#1095219)

- CVE-2018-10887: It has been discovered that an
unexpected sign extension in git_delta_apply function in
delta.c file may have lead to an integer overflow which
in turn leads to an out of bound read, allowing to read
before the base object. An attacker could have used this
flaw to leak memory addresses or cause a Denial of
Service. (bsc#1100613)

- CVE-2018-10888: A missing check in git_delta_apply
function in delta.c file, may lead to an out-of-bound
read while reading a binary delta file. An attacker may
use this flaw to cause a Denial of Service.
(bsc#1100612)

- CVE-2018-15501: A remote attacker can send a crafted
smart-protocol 'ng' packet that lacks a '\0' byte to
trigger an out-of-bounds read that leads to DoS.
(bsc#1104641)

This update was imported from the SUSE:SLE-12-SP2:Update update
project.

Solution

Update the affected libgit2 packages.

See Also

https://bugzilla.opensuse.org/show_bug.cgi?id=1085256

https://bugzilla.opensuse.org/show_bug.cgi?id=1095219

https://bugzilla.opensuse.org/show_bug.cgi?id=1100612

https://bugzilla.opensuse.org/show_bug.cgi?id=1100613

https://bugzilla.opensuse.org/show_bug.cgi?id=1104641

Plugin Details

Severity: Medium

ID: 118486

File Name: openSUSE-2018-1314.nasl

Version: 1.1

Type: local

Agent: unix

Published: 2018/10/29

Modified: 2018/10/29

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 6.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

CVSS v3.0

Base Score: 8.1

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:H

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:libgit2-24, p-cpe:/a:novell:opensuse:libgit2-24-32bit, p-cpe:/a:novell:opensuse:libgit2-24-debuginfo, p-cpe:/a:novell:opensuse:libgit2-24-debuginfo-32bit, p-cpe:/a:novell:opensuse:libgit2-debugsource, p-cpe:/a:novell:opensuse:libgit2-devel, cpe:/o:novell:opensuse:42.3

Patch Publication Date: 2018/10/26

Reference Information

CVE: CVE-2018-10887, CVE-2018-10888, CVE-2018-11235, CVE-2018-15501, CVE-2018-8099